summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-fastcgi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-fastcgi')
-rw-r--r--dev-python/python-fastcgi/Manifest1
-rw-r--r--dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch15
-rw-r--r--dev-python/python-fastcgi/metadata.xml8
-rw-r--r--dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild30
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-fastcgi/Manifest b/dev-python/python-fastcgi/Manifest
new file mode 100644
index 000000000000..e271b0ab42fb
--- /dev/null
+++ b/dev-python/python-fastcgi/Manifest
@@ -0,0 +1 @@
+DIST python-fastcgi-1.1.tar.gz 11180 SHA256 3dff515aecbda371fe5bcb4e449109ce72120ce7bb1edd0e7c2138e75528fd12 SHA512 316c5b07342d27bbad90704909d7a010997801527a9069d23e39975bd3a0e82ab7407bb5e5aa9bdf240039d4c2fec37887540c569d496ca3a328f3323390da89 WHIRLPOOL 9a31809c5ca331b45fa2ab3f2819de4ca0a92fe00c08bfaad6abee8551ccfac56a108dc3b353aed889c85a8563f9a0238da45a6042731522618bfe1cd0583aeb
diff --git a/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
new file mode 100644
index 000000000000..6ce721a5e004
--- /dev/null
+++ b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
@@ -0,0 +1,15 @@
+--- setup.py
++++ setup.py
+@@ -4,11 +4,7 @@
+ from setuptools import setup, Extension
+
+
+-c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"],
+- include_dirs=["/usr/local/include"],
+- library_dirs=["/usr/local/lib"],
+- #extra_link_args=["-s"],
+- )
++c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"])
+
+ setup(name="python-fastcgi",
+ version="1.1",
diff --git a/dev-python/python-fastcgi/metadata.xml b/dev-python/python-fastcgi/metadata.xml
new file mode 100644
index 000000000000..6a01fd7dc0a1
--- /dev/null
+++ b/dev-python/python-fastcgi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">python-fastcgi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
new file mode 100644
index 000000000000..51caeb946400
--- /dev/null
+++ b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK"
+HOMEPAGE="http://pypi.python.org/pypi/python-fastcgi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}