summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-fastimport
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-fastimport')
-rw-r--r--dev-python/python-fastimport/Manifest1
-rw-r--r--dev-python/python-fastimport/metadata.xml12
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-fastimport/Manifest b/dev-python/python-fastimport/Manifest
new file mode 100644
index 000000000000..4798dc338fb7
--- /dev/null
+++ b/dev-python/python-fastimport/Manifest
@@ -0,0 +1 @@
+DIST python-fastimport-0.9.2.tar.gz 30762 SHA256 fd60f1173e64a5da7c5d783f17402f795721b7548ea3a75e29c39d89a60f261e SHA512 8fd9f89267ca88edff94cea7537740431d02680a1eebd085ee376954b47bf5222e7575750895d0d2da246694cdac7a5afe50d857b87c0f36e04eb3511bcbe472 WHIRLPOOL f1d26b8de2180d55f11df3eb937ae3a524b5f55295d264f23a1edd582152cb6ecbc52cba4164e85f5be943c132cb48db0fa3a704eeda5b1c12896233f18d3c76
diff --git a/dev-python/python-fastimport/metadata.xml b/dev-python/python-fastimport/metadata.xml
new file mode 100644
index 000000000000..04f469d57e27
--- /dev/null
+++ b/dev-python/python-fastimport/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <herd>bazaar</herd>
+ <upstream>
+ <remote-id type="launchpad">python-fastimport</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..0b0fb09e45c9
--- /dev/null
+++ b/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://launchpad.net/python-fastimport"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ local test_runner=( "${PYTHON}" -m unittest )
+
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ test_runner=( unit2 )
+ fi
+
+ "${test_runner[@]}" fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}