summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 04:05:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 04:07:38 -0500
commit45c809a969b29e0df14e5244a5099bde772c2970 (patch)
treeb56e682924ba7c6aaaa647d0f434e04f93b8eb10 /dev-python/python-ironicclient
parentdev-python/websockify: liberty bup (diff)
downloadgentoo-45c809a969b29e0df14e5244a5099bde772c2970.tar.gz
gentoo-45c809a969b29e0df14e5244a5099bde772c2970.tar.bz2
gentoo-45c809a969b29e0df14e5244a5099bde772c2970.zip
dev-python/python-ironicclient: bumping for openstack liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/python-ironicclient')
-rw-r--r--dev-python/python-ironicclient/Manifest1
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/Manifest b/dev-python/python-ironicclient/Manifest
index cb47a128d413..9d8d0bfd89d4 100644
--- a/dev-python/python-ironicclient/Manifest
+++ b/dev-python/python-ironicclient/Manifest
@@ -1 +1,2 @@
DIST python-ironicclient-0.5.1.tar.gz 85524 SHA256 91dca5039ca06d6dcd74a132a261db1d85ebf6dcdfb9d7cee4efff657f6729d6 SHA512 787052c79341f44df1520c1f94a59574cb2a6dd5ecbcd23c5ced6dcec75decb310f082fdc5dc6d0ac7c86a8007fcd72ebeb0c25ca940e4e4a4eb635b661c10b8 WHIRLPOOL 4e00b4733814ce415a5dbe551f48e0367f5fd18733c3ecb171b06321c4145330949df2627b51797a2c4f8eaf094379d58e7c329bd322925c752a46394e89cc2f
+DIST python-ironicclient-0.9.0.tar.gz 95562 SHA256 8de88260f30625c6eb8c38fa3401945b510485e00189edaa18ca745b738f6a9a SHA512 324aec8ed9861ce2df4b7783b7bd8b98e30efbc8775ddcb4668f760d8916248df0d32def5cb2d30e9e743ff30e5b6717c653ca6e5cb9ea25b536a369ac45be5d WHIRLPOOL 8d992fff69724706b0a2becf84fd2312bba9be59e7b7103f39a0d5905553d9926510ae6dedd28c4f8ed51c179ddfa2cee97f78c7d2cdc59bb86b8b2fd9cb75de
diff --git a/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild
new file mode 100644
index 000000000000..92320af85102
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+CRDEPEND="
+ >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ ${CRDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ dev-python/doc8[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.4[${PYTHON_USEDEP}]
+ <dev-python/httpretty-0.8.7[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${CRDEPEND}
+"
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}