summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-09-18 23:14:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-09-18 23:14:39 -0500
commit7fa9f98d4f91db1be34afae3306337158c8df28c (patch)
treeadd194c5cee578c64bf3b926c3c664cd0856061f /dev-python/python-troveclient
parentmedia-tv/kodi: enable texturepacker again and depend on giflib #558678 (diff)
downloadgentoo-7fa9f98d4f91db1be34afae3306337158c8df28c.tar.gz
gentoo-7fa9f98d4f91db1be34afae3306337158c8df28c.tar.bz2
gentoo-7fa9f98d4f91db1be34afae3306337158c8df28c.zip
dev-python/python-troveclient: bup for bug 560754
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/python-troveclient')
-rw-r--r--dev-python/python-troveclient/Manifest1
-rw-r--r--dev-python/python-troveclient/python-troveclient-1.3.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/python-troveclient/Manifest b/dev-python/python-troveclient/Manifest
index cf51e2c54044..01392b9d060d 100644
--- a/dev-python/python-troveclient/Manifest
+++ b/dev-python/python-troveclient/Manifest
@@ -1 +1,2 @@
DIST python-troveclient-1.0.5.tar.gz 97125 SHA256 f758c01ae770ec9e58b71ebc78c6e3f975a9d37d09820b512df77c827b2b921e SHA512 0912e93879cf59b41f461d59e85c421be61491cc7c58dd65a3474e479fd6b1bca016ac188938ac186bd6d005a5415c8f1cf00c88a3390d6fc8e1da4d3e0c3997 WHIRLPOOL b73db090e9b6bf5d64404cc8ec13b88a3e564a5b1a74512b95daea09190308026ac87db888d6160272eda3719e10a573104801dddbf2085cde483f64a9499d64
+DIST python-troveclient-1.3.0.tar.gz 130542 SHA256 abb0a5bf2442bd396322c65ea7b386d043e3fcffdaeed6a61d63d8be1a8452f2 SHA512 aa26b587d8e2bd15bb65ff760b89354638f6a77a4e73ec5f37ab6dc3c374d6b8c238391c09347e7fc897138fc0bdc375f69ab479f57e14f21d0882b74cc7c978 WHIRLPOOL 02490089bfea489b51e07f4da5b3ea5bbe2e839c2751c5e98ae384195465fca861a7d156e5ea179a6879d3b44c318e30f560314619705a3d8a3ac7b0f0606752
diff --git a/dev-python/python-troveclient/python-troveclient-1.3.0.ebuild b/dev-python/python-troveclient/python-troveclient-1.3.0.ebuild
new file mode 100644
index 000000000000..94b3bd7286ac
--- /dev/null
+++ b/dev-python/python-troveclient/python-troveclient-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Trove API, a scalable relational database service"
+HOMEPAGE="https://github.com/openstack/python-troveclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run --parallel || die "testsuite failed under python2.7"
+}