summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-03 23:07:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-03 23:07:16 +0200
commit75d89b95a3985e3723c3e1e64aac2a3919cefc6e (patch)
treefcff078b636e3c1917d11b0c686d580d6c80bfc2 /dev-python/pytz
parentdev-python/psutil: Version bump to 4.1.0 (diff)
downloadgentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.tar.gz
gentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.tar.bz2
gentoo-75d89b95a3985e3723c3e1e64aac2a3919cefc6e.zip
dev-python/pytz: Version bump to 2016.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2016.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index f38e08060e24..1da34e98c952 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,3 +1,4 @@
DIST pytz-2015.4.tar.bz2 157361 SHA256 a78b484d5472dd8c688f8b3eee18646a25c66ce45b2c26652850f6af9ce52b17 SHA512 ade31780d5d91cb519e69b38f8828e1cf94b5b388a3efd80db42b7a5e5603f43f5726f7aecfd08c78d3637a3017910f3ed1a7727ec291f6579a41882c6289ca4 WHIRLPOOL 7804617d21de5e6212ccc1f17651c8e76a94374af22f542cd6eb54fc6951d0b6ec42cd7623162074994573b6bba492d92397a584277b423742c15b68cb930ae7
DIST pytz-2015.6.tar.bz2 156925 SHA256 01eed1b2226dc386d8e467a2ff8c4f1aa08c65d5d7e7c43aa094bd45d5bd68ba SHA512 e6e117d85c0a0310b115cfaae2b9d5957641f8367a7890f4e1afed8129e77c6a08b733b985c06d5f3fe5bbfa565387826883864b79dd4946065561a60ad24f35 WHIRLPOOL 255684e9f24353aeda2f26fc89216aef3b34a87a74df4dc758f87da31cedce6d372d405d37e8c538b786324c6ce03da177d3429438999ecfd744009fd7bbbbe9
DIST pytz-2015.7.tar.bz2 156812 SHA256 fbd26746772c24cb93c8b97cbdad5cb9e46c86bbdb1b9d8a743ee00e2fb1fc5d SHA512 ffdea72f36b286ea63a3dbc022626ab01d2348ebd29c3532e9e1a289c3112f0ff01e9f3fcf2ad389b609d14393b68c9652f61d1589551f4979a010185da0609c WHIRLPOOL 3ed0deee15f831ae735a9d4f317fe1eaca91e10f450343b0a1e24998846785fd5b02c71caa4ee4e40e426fdc780e2ac9ccaf54abc1f7a66c662bef84feacd691
+DIST pytz-2016.3.tar.bz2 170906 SHA256 c193dfa167ac32c8cb96f26cbcd92972591b22bda0bac3effdbdb04de6cc55d6 SHA512 8d91a84500257327361a8ccd19ce2d2e5848c10c7d4105ec1be012be592ec38113611558c7894c1825cc1967303901fce35079fc799cc10e84216864cd00266f WHIRLPOOL b2af20a788fa70c23b04cda3acdff812c30713f00a9aaf2144d85c64341f6fe4e365b558f3f0b5491c6c99ebf633d2d3910c95f7a6ae1f9c53b40da6bcbc23af
diff --git a/dev-python/pytz/pytz-2016.3.ebuild b/dev-python/pytz/pytz-2016.3.ebuild
new file mode 100644
index 000000000000..55874844f570
--- /dev/null
+++ b/dev-python/pytz/pytz-2016.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.python.org/pypi/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sys-libs/timezone-data-2015g"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/${PN}-2009j-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2009h-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}