summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/raven
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/raven')
-rw-r--r--dev-python/raven/Manifest2
-rw-r--r--dev-python/raven/metadata.xml12
-rw-r--r--dev-python/raven/raven-5.2.0.ebuild23
-rw-r--r--dev-python/raven/raven-5.3.0.ebuild23
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/raven/Manifest b/dev-python/raven/Manifest
new file mode 100644
index 000000000000..044fe18977e6
--- /dev/null
+++ b/dev-python/raven/Manifest
@@ -0,0 +1,2 @@
+DIST raven-5.2.0.tar.gz 225471 SHA256 01f90e5b15a6676d5ea360e09fb0cd926edad7332584c67d83dc4371c10307aa SHA512 a7e82d9060f466500e429c119a184da1f437632dae76dfd3b24b2101e3fcf0e7fcf8b7371c299e5174c15516c127a3e437269d62d908c59f02c587f3ab528b21 WHIRLPOOL 39e50c0b79f97ec58fdc5d7cee339afd8da4efe8d063361391eb39bdcced36313f08971b93b624b97adbd06895b905b76104757042ee599228316c82cc92391d
+DIST raven-5.3.0.tar.gz 319160 SHA256 271c6eda8763b885eb514e3fc2271b59ae62099c8e9371332180059a298e01ba SHA512 805a0910aea0eed73704dc57a32482a5b01501c27c788c105b84d12241480e70d1454ab54d924e6c8e5ef03764ed5759fc79482ee24417e801e9634353160df2 WHIRLPOOL 2eb3deaff1e029fe1c2c1711e36d939ecef2849401a2b9dad8b5295c9e77ba1dc98ca8024639a1fac13e19f7dd49b0fffc478b513a1c4f18447de8b08d38ed99
diff --git a/dev-python/raven/metadata.xml b/dev-python/raven/metadata.xml
new file mode 100644
index 000000000000..2646b9e2fe25
--- /dev/null
+++ b/dev-python/raven/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">raven</remote-id>
+ <remote-id type="github">getsentry/raven-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/raven/raven-5.2.0.ebuild b/dev-python/raven/raven-5.2.0.ebuild
new file mode 100644
index 000000000000..648cadc46122
--- /dev/null
+++ b/dev-python/raven/raven-5.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raven is a client for Sentry"
+HOMEPAGE="http://github.com/getsentry/raven-python"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/raven/raven-5.3.0.ebuild b/dev-python/raven/raven-5.3.0.ebuild
new file mode 100644
index 000000000000..648cadc46122
--- /dev/null
+++ b/dev-python/raven/raven-5.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raven is a client for Sentry"
+HOMEPAGE="http://github.com/getsentry/raven-python"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"