summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:11:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:47:12 +0200
commit3e3402c2423ef877d21b943876f82a6110bdedc5 (patch)
treedb2a508aa708005dada3cee2ae848aac9f630e86 /dev-python/rdflib
parentdev-python/pyrsistent: Bump to version 0.12.1 (diff)
downloadgentoo-3e3402c2423ef877d21b943876f82a6110bdedc5.tar.gz
gentoo-3e3402c2423ef877d21b943876f82a6110bdedc5.tar.bz2
gentoo-3e3402c2423ef877d21b943876f82a6110bdedc5.zip
dev-python/rdflib: Bump to version 4.2.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-4.2.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index cdb4182e954a..b64e32fe1fa9 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1 +1,2 @@
DIST rdflib-4.2.1.tar.gz 889467 SHA256 eb02bd235606ef3b26e213da3e576557a6392ce103efd8c6c8ff1e08321608c8 SHA512 49145f80a9e027847523faed059c16ec1de358bb9d8fc3ab4fd3bf95a88dd181986b1785deedf6e837cf0b064bd74ab8e27fbb5581e33310353da3546ae7b016 WHIRLPOOL 010bb4cf7c544b9a3f28636182b6c1821f390066bfe3de59f58fb7cfd8d809d8b0b5f256134b9c5091327c7ba6319be02135d6ea8a6d8b37772e212f000c3ba7
+DIST rdflib-4.2.2.tar.gz 905094 SHA256 da1df14552555c5c7715d8ce71c08f404c988c58a1ecd38552d0da4fc261280d SHA512 efc24d8ce1080e59950cecc9c779ae0d63673c8690f74db1772f6c2dbf24d6f4de5214d5870a074bffe549b42d8d5f5d131df29bbfd174b763ae1f843aec7d5c WHIRLPOOL f270e89354e601b17a91fb415a01f44ddaf90fec71e71997007f72db15275cae17bb4f2e45e2aacc852d748beda2907e5dc48c930c12632bf5846af335d7ac09
diff --git a/dev-python/rdflib/rdflib-4.2.2.ebuild b/dev-python/rdflib/rdflib-4.2.2.ebuild
new file mode 100644
index 000000000000..2e188fc2ed8b
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/conf.py || die
+
+ # doc build requires examples folder at the upper level of docs
+ if use doc; then
+ cd docs || die
+ ln -sf ../examples . || die
+ cd ../ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/RDFLib/rdflib/issues/510
+ if use doc; then
+ einfo ""; einfo "Several warnings and Errors present in the build"
+ einfo "For a complete build, it is required to install"
+ einfo "github.com/gjhiggins/n3_pygments_lexer and"
+ einfo "github.com/gjhiggins/sparql_pygments_lexer"
+ einfo "outside portage via pip or by cloning. These have not been"
+ einfo "given a tagged release by the author and are not in portage"
+ einfo ""
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # the default; nose with: --where=./ does not work for python3
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}