summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-20 00:31:06 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-20 00:32:31 +0800
commit55e8bb9e208ac9eda033095d280b07f74650df03 (patch)
tree2b763559f8e475a3de4778d2fbe4dca34b6a3d94 /dev-python/rdflib
parentsys-kernel/hardened-sources: add 4.1.6 (diff)
downloadgentoo-55e8bb9e208ac9eda033095d280b07f74650df03.tar.gz
gentoo-55e8bb9e208ac9eda033095d280b07f74650df03.tar.bz2
gentoo-55e8bb9e208ac9eda033095d280b07f74650df03.zip
dev-python/rdflib: bump, rm unneeded var DISTUTILS_NO_PARALLEL_BUILD
Add doc build, info to user re Warnings and Errors and optional packages for build, rm old disused patch, drop recent patch now merged in bumped release Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/files/rdflib-3.1.0-test.patch20
-rw-r--r--dev-python/rdflib/rdflib-4.2.0.ebuild6
-rw-r--r--dev-python/rdflib/rdflib-4.2.1.ebuild87
4 files changed, 91 insertions, 23 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index 8f4d6b4e192b..dd258bd60808 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1,3 +1,4 @@
DIST rdflib-3.2.3.tar.gz 449077 SHA256 a3cab51c14fa6fe379261e0157c110d94e2f75ef62073ddc76fe56f5be624b75 SHA512 92697be6d6bba4e31303b46c2a42defd840770f75c6f359b7338fa3d48a2001cdcda3b6319403ad0c9f1696051d773b146c9b012770df81b4d94a34d30f6b02a WHIRLPOOL b41794febee280022990dac8c4e177660f69803f01fc14ade194015bc6cf1eaf23164620b09cf1123445d181c0bbe9f0733b901cddafb126bcd711d0462a9f7b
DIST rdflib-4.1.2.tar.gz 868883 SHA256 3cf94bda0867f21468b248ce9f671581efb92ae9edd28ff321716126c6706a4f SHA512 99d4a4b4d37808563575ac13312cf0e0975f7c1563117cfe7e4b70a84a2804f7eb57144d6a7c629c109ff7b236a6ea2489a4925ae41791274f3b234143837e65 WHIRLPOOL 090e00cc3113cec158f786a39103450f0d1d25571ad57c346120756901f01b0fcf20ff731ae3b174b54f3621e46a26061eee7bd774ffdf91380f4a3647380590
DIST rdflib-4.2.0.tar.gz 881424 SHA256 7420dafc4930249d0cfcf31e8547a39b658d079ab2c9e975465f6697a8476ec0 SHA512 7677869eb0a65ede317634253042da68b4e183d5352cd37bd949380eb29deec8329336067a2ab686c90d6a1718f8e7a9039424753846d879cce41c05f656735f WHIRLPOOL 62f67318ade0fee1d5d64d6294aa821f4f06f940b18e421d43292e749e495cb3e348b522dd79eec805ce88125d8a6864dccc4a4037ed0a52d5aed616e51b39f5
+DIST rdflib-4.2.1.tar.gz 889467 SHA256 eb02bd235606ef3b26e213da3e576557a6392ce103efd8c6c8ff1e08321608c8 SHA512 49145f80a9e027847523faed059c16ec1de358bb9d8fc3ab4fd3bf95a88dd181986b1785deedf6e837cf0b064bd74ab8e27fbb5581e33310353da3546ae7b016 WHIRLPOOL 010bb4cf7c544b9a3f28636182b6c1821f390066bfe3de59f58fb7cfd8d809d8b0b5f256134b9c5091327c7ba6319be02135d6ea8a6d8b37772e212f000c3ba7
diff --git a/dev-python/rdflib/files/rdflib-3.1.0-test.patch b/dev-python/rdflib/files/rdflib-3.1.0-test.patch
deleted file mode 100644
index aea1bf5ac723..000000000000
--- a/dev-python/rdflib/files/rdflib-3.1.0-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
- rdflib/__init__.py | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/rdflib/__init__.py b/rdflib/__init__.py
-index b781031..44efb0b 100644
---- a/rdflib/__init__.py
-+++ b/rdflib/__init__.py
-@@ -15,10 +15,10 @@ A tiny example:
- >>> import rdflib
-
- >>> g = rdflib.Graph()
-- >>> result = g.parse("http://eikeon.com/foaf.rdf")
-+ >>> result = g.parse("http://www.w3.org/2000/10/swap/test/meet/white.rdf")
-
- >>> print "graph has %s statements." % len(g)
-- graph has 34 statements.
-+ graph has 19 statements.
- >>>
- >>> for s, p, o in g:
- ... if (s, p, o) not in g:
diff --git a/dev-python/rdflib/rdflib-4.2.0.ebuild b/dev-python/rdflib/rdflib-4.2.0.ebuild
index 88878bec6ec2..e18f716ab273 100644
--- a/dev-python/rdflib/rdflib-4.2.0.ebuild
+++ b/dev-python/rdflib/rdflib-4.2.0.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
+
# The usual required for tests
DISTUTILS_IN_SOURCE_BUILD=1
@@ -26,8 +26,8 @@ RDEPEND="
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep 'python2*')] )"
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
diff --git a/dev-python/rdflib/rdflib-4.2.1.ebuild b/dev-python/rdflib/rdflib-4.2.1.ebuild
new file mode 100644
index 000000000000..12414be986e1
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite?"
+
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/conf.py || die
+
+ # doc build requires examples folder at the upper level of docs
+ if use doc; then
+ cd docs || die
+ ln -sf ../examples . || die
+ cd ../ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/RDFLib/rdflib/issues/510
+ if use doc; then
+ einfo ""; einfo "Several warnings and Errors present in the build"
+ einfo "For a complete build, it is required to install"
+ einfo "github.com/gjhiggins/n3_pygments_lexer and"
+ einfo "github.com/gjhiggins/sparql_pygments_lexer"
+ einfo "outside portage via pip or by cloning. These have not been"
+ einfo "given a tagged release by the author and are not in portage"
+ einfo ""
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # the default; nose with: --where=./ does not work for python3
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/../docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
+