summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-19 17:18:59 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-19 18:05:31 +0800
commitc553a4a14ed8180d86daa7e26e840d07eeb0df7b (patch)
treebf2a9a4f3efeaeb608ff8267b471b73ac016a171 /dev-python/rdflib
parentapp-crypt/gnupg: add threads USE for libgcrypt (diff)
downloadgentoo-c553a4a14ed8180d86daa7e26e840d07eeb0df7b.tar.gz
gentoo-c553a4a14ed8180d86daa7e26e840d07eeb0df7b.tar.bz2
gentoo-c553a4a14ed8180d86daa7e26e840d07eeb0df7b.zip
dev-python/rdflib: take out doctests from test phase, fixes Bug #358189
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild6
-rw-r--r--dev-python/rdflib/rdflib-4.2.0.ebuild7
2 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
index da5d38550c97..ea599e27a076 100644
--- a/dev-python/rdflib/rdflib-4.1.2.ebuild
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -1,3 +1,4 @@
+
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,6 +37,11 @@ DEPEND="${RDEPEND}
python_prepare_all() {
# Upstream manufactured .pyc files which promptly break distutils' src_test
find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
distutils-r1_python_prepare_all
}
diff --git a/dev-python/rdflib/rdflib-4.2.0.ebuild b/dev-python/rdflib/rdflib-4.2.0.ebuild
index 9ab19201e212..294c0a58657f 100644
--- a/dev-python/rdflib/rdflib-4.2.0.ebuild
+++ b/dev-python/rdflib/rdflib-4.2.0.ebuild
@@ -23,7 +23,7 @@ IUSE="berkdb examples mysql redland sqlite test"
RDEPEND="
dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[$(python_gen_usedep 'python2*')]
+ dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
@@ -36,6 +36,11 @@ DEPEND="${RDEPEND}
python_prepare_all() {
# Upstream manufactured .pyc files which promptly break distutils' src_test
find -name "*.py[oc~]" -delete || die
+
+ # Bug 358189; take out tests that attempt to connect to the network
+ sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
+ -e "/'--doctest-tests',/d" -i run_tests.py || die
+
distutils-r1_python_prepare_all
}