summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/readme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/readme')
-rw-r--r--dev-python/readme/Manifest3
-rw-r--r--dev-python/readme/metadata.xml9
-rw-r--r--dev-python/readme/readme-0.4.1.ebuild41
-rw-r--r--dev-python/readme/readme-0.4.2.ebuild41
-rw-r--r--dev-python/readme/readme-0.5.1.ebuild41
5 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/readme/Manifest b/dev-python/readme/Manifest
new file mode 100644
index 000000000000..abdce5ca448d
--- /dev/null
+++ b/dev-python/readme/Manifest
@@ -0,0 +1,3 @@
+DIST readme-0.4.1.tar.gz 9318 SHA256 baf79dc0312ee4cf49291412916a120051b1b0977b5b7f883c550fb426a6a690 SHA512 937610e49fe2b94d8a5e924c02e99194bfe453bf73c03f73514dbd30412f556b81af2fa6ddfc5352f8eccc3706065f7e8302403d6060a6dc6719a7fabd1251ee WHIRLPOOL 405dc4a3b71ef7da42a333a63cb0ecc7dad3cb8d3ff9bc1fecd60d001700c1676e0f2ca4d7b9a08bb38c957cce5bb99cdba997f14d2c30fe5bee4f7ffc2a803d
+DIST readme-0.4.2.tar.gz 9329 SHA256 2ae289e4090991b9f7e0a1da210444c2b91f57257da226b5dfd4eadff0b6e5b1 SHA512 83db9dc4042a9079380cefef753c88b2a65e7905fa3715260a03d78d2ed00e12f60425626d254cd7cb2b945216b6fb062ffec1d9073cbc7619957744dfcaab25 WHIRLPOOL 3d635805f20a80f5d30e418bb1971ed81833ec4cb13416efd18a4a51c28479d21ba37f318023f17128afc8795a4b62bd0251a2cbbb34bf6b932ee15f6e71c733
+DIST readme-0.5.1.tar.gz 9917 SHA256 4d33851d7fa56d1f93b7ba979ebbb17b5175ccde9fd9dfb974427bdd72ec667b SHA512 50cbd71e692be0b6cba06d85765946aa2d2d751f3f44563c5a6902ecc982658e5e3b1e01cbaf50a4df4dc61a56290e67b71eb88c109cbb830af36f0d334552c2 WHIRLPOOL f53d900d9764c59053db1350fe059a45d1faed43f7d53468ebf3d88dfea44fe69ffb22e80483e69c4b24708fd75963a034e429325b5844375a11202ce7877a23
diff --git a/dev-python/readme/metadata.xml b/dev-python/readme/metadata.xml
new file mode 100644
index 000000000000..c4cf8bf04860
--- /dev/null
+++ b/dev-python/readme/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">readme</remote-id>
+ <remote-id type="github">pypa/readme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/readme/readme-0.4.1.ebuild b/dev-python/readme/readme-0.4.1.ebuild
new file mode 100644
index 000000000000..99b0b0f471fb
--- /dev/null
+++ b/dev-python/readme/readme-0.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
+HOMEPAGE="https://github.com/pypa/readme https://pypi.python.org/pypi/readme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+ # remove failing test for now
+ rm tests/fixtures/test_rst_008* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/readme/readme-0.4.2.ebuild b/dev-python/readme/readme-0.4.2.ebuild
new file mode 100644
index 000000000000..99b0b0f471fb
--- /dev/null
+++ b/dev-python/readme/readme-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
+HOMEPAGE="https://github.com/pypa/readme https://pypi.python.org/pypi/readme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+ # remove failing test for now
+ rm tests/fixtures/test_rst_008* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/readme/readme-0.5.1.ebuild b/dev-python/readme/readme-0.5.1.ebuild
new file mode 100644
index 000000000000..99b0b0f471fb
--- /dev/null
+++ b/dev-python/readme/readme-0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
+HOMEPAGE="https://github.com/pypa/readme https://pypi.python.org/pypi/readme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+ # remove failing test for now
+ rm tests/fixtures/test_rst_008* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}