summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/Manifest3
-rw-r--r--dev-python/rpy/files/2.5.0-setup.patch45
-rw-r--r--dev-python/rpy/metadata.xml15
-rw-r--r--dev-python/rpy/rpy-2.5.4.ebuild50
-rw-r--r--dev-python/rpy/rpy-2.6.0.ebuild51
-rw-r--r--dev-python/rpy/rpy-2.6.1.ebuild53
6 files changed, 217 insertions, 0 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
new file mode 100644
index 000000000000..4abff86e189a
--- /dev/null
+++ b/dev-python/rpy/Manifest
@@ -0,0 +1,3 @@
+DIST rpy2-2.5.4.tar.gz 164830 SHA256 d521ecdd05cd0c31ab017cb63e9f63c29b524e46ec9063a920f640b5875f8a90 SHA512 e40ae81be19acf5008eed088c10fef3824cc712c0175414c1899bf45b24c35e2ef7d8808fae75d156064e82d1cd5939c50d5291c190030ae2050c6dffa9a36db WHIRLPOOL 2769adccaa6a634b964d4712e4bcc4d4161f8aef17d38a235bf5a3646fd166a01749fcc1852954996a00b695617597617f0dfb43f73744948a55f2eba07d9ba2
+DIST rpy2-2.6.0.tar.gz 171190 SHA256 53e295f3018a781008bffb97cc0c9a7cd361a3d191939f197157827d21a2e4b6 SHA512 16012a8a634538ba61e392dc811615a870b94b348c7ece885f8c0d146419b9689a08d5901ed2a694754cc220664797d530f75ba35e395f5857a0f25c3170f3ce WHIRLPOOL 1f33e99f1997ffbc1e9711bb667ba07db024099bdf7e460a13efe311419b872095128b2d59ffb732384ca19b77dac97822bbcf8e77ff45b0b093d7b5cfbc83e5
+DIST rpy2-2.6.1.tar.gz 171635 SHA256 39f15d7f5d51646a6cbf9d5cd1c817d2880301dbb95141947f93361685453e28 SHA512 14c6c47d6ace40ac26bf89d3efdbf5c5a68f74096fec74897877be312d3ffb03c30f4ca13ed1531ccf094ac33672fa550264fe980788bc4eca12d02089475f63 WHIRLPOOL dda6a0a2abe33f8d7e3a489c6bbaa03335a47d5fa474409883773a52be315f0920347a38f76f94e9e16c680e08cd8e7a18d27a6a2ffd4af35a779a305836bdd5
diff --git a/dev-python/rpy/files/2.5.0-setup.patch b/dev-python/rpy/files/2.5.0-setup.patch
new file mode 100644
index 000000000000..2454c313e677
--- /dev/null
+++ b/dev-python/rpy/files/2.5.0-setup.patch
@@ -0,0 +1,45 @@
+https://bitbucket.org/lgautier/rpy2/commits/bf38fa9960aa
+# HG changeset patch
+# User Laurent Gautier <lgautier@gmail.com>
+# Date 1415656651 18000
+# Node ID bf38fa9960aacf7ba24a20cfae631aa695fea986
+# Parent 9c1212066f5c980a211b21943f62fd69743ca4bd
+Should fix issue #234
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -136,8 +136,6 @@
+ return output
+
+ def getRinterface_ext():
+- #r_libs = [os.path.join(RHOME, 'lib'), os.path.join(RHOME, 'modules')]
+- r_libs = []
+ extra_link_args = []
+ extra_compile_args = []
+ include_dirs = []
+@@ -250,9 +248,9 @@
+ include_dirs = [os.path.join(package_prefix,
+ 'rpy', 'rinterface'),] + include_dirs,
+ libraries = libraries,
+- library_dirs = r_libs,
++ library_dirs = library_dirs,
+ define_macros = define_macros,
+- runtime_library_dirs = r_libs,
++ runtime_library_dirs = library_dirs,
+ extra_compile_args=extra_compile_args,
+ extra_link_args = extra_link_args
+ )
+@@ -266,9 +264,9 @@
+ include_dirs = include_dirs +
+ [os.path.join('rpy', 'rinterface'), ],
+ libraries = libraries,
+- library_dirs = r_libs,
++ library_dirs = library_dirs,
+ define_macros = define_macros,
+- runtime_library_dirs = r_libs,
++ runtime_library_dirs = library_dirs,
+ extra_compile_args=extra_compile_args,
+ extra_link_args = extra_link_args
+ )
+
diff --git a/dev-python/rpy/metadata.xml b/dev-python/rpy/metadata.xml
new file mode 100644
index 000000000000..44f552728e03
--- /dev/null
+++ b/dev-python/rpy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ RPy provides a robust Python interface to the R programming
+ language. It can manage R objects and can execute arbitrary R
+ functions. All the errors from the R language are converted to
+ Python exceptions.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">rpy2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rpy/rpy-2.5.4.ebuild b/dev-python/rpy/rpy-2.5.4.ebuild
new file mode 100644
index 000000000000..fd4fe9abfcd3
--- /dev/null
+++ b/dev-python/rpy/rpy-2.5.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
+
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+# Tarball absent of doc files in doc folder
+# https://bitbucket.org/lgautier/rpy2/issue/229/
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' || die
+}
diff --git a/dev-python/rpy/rpy-2.6.0.ebuild b/dev-python/rpy/rpy-2.6.0.ebuild
new file mode 100644
index 000000000000..ea9c6e695eec
--- /dev/null
+++ b/dev-python/rpy/rpy-2.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
+
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+# Tarball absent of doc files in doc folder
+# https://bitbucket.org/lgautier/rpy2/issue/229/
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' || die
+}
diff --git a/dev-python/rpy/rpy-2.6.1.ebuild b/dev-python/rpy/rpy-2.6.1.ebuild
new file mode 100644
index 000000000000..de5f7205b05f
--- /dev/null
+++ b/dev-python/rpy/rpy-2.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
+
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+# Tarball absent of doc files in doc folder
+# https://bitbucket.org/rpy2/rpy2/issues/229
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' || die
+}