summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-21 16:31:59 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 16:32:07 +0200
commitbdc7d9e978f3f2da137c1ae79d2715cff0ee813b (patch)
tree22a264fb492b3c5aa06d7725f18f288c2d83e6ed /dev-python/rpy
parentapp-misc/freemind: Clean up broken version. Fixes bug 561488. (diff)
downloadgentoo-bdc7d9e978f3f2da137c1ae79d2715cff0ee813b.tar.gz
gentoo-bdc7d9e978f3f2da137c1ae79d2715cff0ee813b.tar.bz2
gentoo-bdc7d9e978f3f2da137c1ae79d2715cff0ee813b.zip
dev-python/rpy: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/Manifest1
-rw-r--r--dev-python/rpy/rpy-2.7.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index 90514ef46bf5..53c74fc6c326 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1 +1,2 @@
DIST rpy2-2.6.2.tar.gz 171655 SHA256 2e28886b2a6a138cfc057f9b7cddade253e61c9abb43f0eae20dace58b6dfced SHA512 7a060ccc26a03dc93d75edb85d92f1ab31af96ba140932ff8e699cd5855e6078b1e0ffceed135d32deb6c8f273ebcc8b02be38e9b8fc66778cc2adab5745f542 WHIRLPOOL 26d9a9c13e4efa22a232507cfff0b13d650e0528f635dfa9fe464cde50462d2d94a668d1566b537bafaa5462eb66e96005296c6295308b1e3d1c5639da2879b6
+DIST rpy2-2.7.2.tar.gz 176481 SHA256 b8c376c2bb78a602effa44c654633f7a11b9bcc582aa3d4828a11302bc290e21 SHA512 d282e81cdd4c69ac4655d019151e2c7ce0aaeeb55479f7f7405ed16ac4124d2f3eedccb37a7d563deb0d8beb69e5ede4d6702a3872b554965442a38ec545f1f4 WHIRLPOOL f19182a1ef392d1b4029ebd984d8828d92ea3bf14c9375490fa099d7a2f82e99c75eb6475dba1d11270bf76dc94eee490157e22ab2c083c51a90b3c1d1a56b7a
diff --git a/dev-python/rpy/rpy-2.7.2.ebuild b/dev-python/rpy/rpy-2.7.2.ebuild
new file mode 100644
index 000000000000..da88f145ec91
--- /dev/null
+++ b/dev-python/rpy/rpy-2.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3.1
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+# Tarball absent of doc files in doc folder
+# https://bitbucket.org/rpy2/rpy2/issues/229
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' || die
+}