summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-07-25 09:32:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-26 00:34:26 +0200
commit21ed8befb71cb458f7a1e15738042d69dda8cddc (patch)
tree2aad66203f5778d27056948d741db839638044c0 /dev-python/scandir
parentmail-filter/maildrop: Unbreak testsuite patch, closes bug #617992 by Ooblick. (diff)
downloadgentoo-21ed8befb71cb458f7a1e15738042d69dda8cddc.tar.gz
gentoo-21ed8befb71cb458f7a1e15738042d69dda8cddc.tar.bz2
gentoo-21ed8befb71cb458f7a1e15738042d69dda8cddc.zip
dev-python/scandir: new package.
A better directory iterator and faster os.walk(). scandir() is a directory iteration function like os.listdir(), except that instead of returning a list of bare filenames, it yields DirEntry objects that include file type and stat information along with the name. Using scandir() increases the speed of os.walk() by 2-20 times (depending on the platform and file system) by avoiding unnecessary calls to os.stat() in most cases. Required by dev-python/pathlib2[python2_7,python3_4]. Gentoo-Bug: https://bugs.gentoo.org/626120 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5207
Diffstat (limited to 'dev-python/scandir')
-rw-r--r--dev-python/scandir/Manifest1
-rw-r--r--dev-python/scandir/metadata.xml12
-rw-r--r--dev-python/scandir/scandir-1.5.ebuild23
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
new file mode 100644
index 000000000000..778897f42134
--- /dev/null
+++ b/dev-python/scandir/Manifest
@@ -0,0 +1 @@
+DIST scandir-1.5.tar.gz 29351 SHA256 c2612d1a487d80fb4701b4a91ca1b8f8a695b1ae820570815e85e8c8b23f1283 SHA512 e6535e92011cc2c5f888ddd083a9dc48921609fd59d9bf9a4bcd596c055dc0510d48f6d3571605bbade3bd0e232e8bae94b44b20ba935e7ffdeec268ba3d2ee4 WHIRLPOOL 87808f7c76be95956a609ff1246fcd74103129883bad7300fbd5db7f743e9fcc93031d2d95d58cd36eb4bb6f5bcceadd5b77a4d2c2f3ce1d902073b9e55c4140
diff --git a/dev-python/scandir/metadata.xml b/dev-python/scandir/metadata.xml
new file mode 100644
index 000000000000..708fb92089a5
--- /dev/null
+++ b/dev-python/scandir/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">scandir</remote-id>
+ <remote-id type="github">benhoyt/scandir</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/scandir/scandir-1.5.ebuild b/dev-python/scandir/scandir-1.5.ebuild
new file mode 100644
index 000000000000..9c409ca6ffb4
--- /dev/null
+++ b/dev-python/scandir/scandir-1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}