summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-04 18:07:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-05 15:52:58 +0200
commit5f229171722d6a87280097d87a715048b455a74f (patch)
tree76bda7fdfeac6e6c0c8ced0aaecb0b6c2404968a /dev-python/scandir
parentdev-python/schedule: version bump. (diff)
downloadgentoo-5f229171722d6a87280097d87a715048b455a74f.tar.gz
gentoo-5f229171722d6a87280097d87a715048b455a74f.tar.bz2
gentoo-5f229171722d6a87280097d87a715048b455a74f.zip
dev-python/scandir: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/scandir')
-rw-r--r--dev-python/scandir/Manifest1
-rw-r--r--dev-python/scandir/scandir-1.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
index b9f6a616c879..bef789c76446 100644
--- a/dev-python/scandir/Manifest
+++ b/dev-python/scandir/Manifest
@@ -1,2 +1,3 @@
DIST scandir-1.6.tar.gz 29670 BLAKE2B ad8c231783c14246341cd23bd79185ee10894bb29107ba7c0bfdf51982bda99fd8ce45ea52ff42687371d56b3e6d43cf1d6cc65bdaecf43da9059e524a801e6d SHA512 d01e0551696787caded787a430eea787a69a27c725505277420fd607b3fcc892218377bb340651fd906bdeb3a57e99879df3c86aeadd2399fcbe45cb2118b9db
DIST scandir-1.7.tar.gz 32812 BLAKE2B ed80775b5acca85d8829e2fb46df33fdda08d9dad6cc0e175d1270dc51b6eb4d381a5bd813e2dfd2072ac0af0d642d20ae818e569688ffbe5decaf4421f5e979 SHA512 47c6d9642938f374eb03228cdb6c8d77aa2af01a84b7efc518d223851562a615b616e92100bbeb38c4fa7455ef5f7ae4af8d406f5148d1a26a403708b4a27023
+DIST scandir-1.8.tar.gz 33065 BLAKE2B 020789b939f347de49dba6eb35cf53733a34b283a4226d91746dca4f26b0fdcbe708cb48a795085c8887921bdad77c3fd054c15dcf83b1f4624ee81f1735f2da SHA512 9c2c578cc736887e7d1ebe51f62569599e386deeac55363a84cd1abe4f73c60a43ae9849b3570ed99079016908ceab5e3755b014256d1cab535c1677255690f3
diff --git a/dev-python/scandir/scandir-1.8.ebuild b/dev-python/scandir/scandir-1.8.ebuild
new file mode 100644
index 000000000000..f355a307197b
--- /dev/null
+++ b/dev-python/scandir/scandir-1.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}