summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:45:04 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit17c7017a21b618b51bccfcb3559a3ffdb8fd5f7a (patch)
treef770f858ccb45b9002a71a65205af7b8176d247b /dev-python/setuptools_scm
parentdev-python/cython: Add python3.5 support (diff)
downloadgentoo-17c7017a21b618b51bccfcb3559a3ffdb8fd5f7a.tar.gz
gentoo-17c7017a21b618b51bccfcb3559a3ffdb8fd5f7a.tar.bz2
gentoo-17c7017a21b618b51bccfcb3559a3ffdb8fd5f7a.zip
dev-python/setuptools_scm: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.8.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.8.0-r1.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..aa939b2a6604
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.8.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v -v -x || die "tests failed under ${EPYTHON}"
+}