summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simpleeval
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simpleeval')
-rw-r--r--dev-python/simpleeval/Manifest2
-rw-r--r--dev-python/simpleeval/metadata.xml15
-rw-r--r--dev-python/simpleeval/simpleeval-0.8.2.ebuild22
-rw-r--r--dev-python/simpleeval/simpleeval-0.8.5.ebuild28
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/simpleeval/Manifest b/dev-python/simpleeval/Manifest
new file mode 100644
index 000000000000..59a820c68612
--- /dev/null
+++ b/dev-python/simpleeval/Manifest
@@ -0,0 +1,2 @@
+DIST simpleeval-0.8.2.tar.gz 8282 SHA256 828e79056ae2083ff6091dd8d33855974300241c3dd7d4a173faf901a17c7b09 SHA512 288d597c646ee0c70e3a6e04fd8db112b7b7a00ad53101114cc1724110c2f71d7b5f382f9052ebdb8dbc6b48c1391c870966b72df368701548d513d3053c1759 WHIRLPOOL 88edf67da8cda1bc1ab0c66a908fc12b2e5a4b14db9f6f0e8dc771c53a4c731c38d2dbad3a8d2c2f2d8efc3b3f86ed7be1eceffa5c3d5b8cd5a096ee99c87d5c
+DIST simpleeval-0.8.5.tar.gz 13858 SHA256 76fb692abfc45c57a25540b976ddb4b3029162015e4f13735ac783bc4437a99b SHA512 da913e7dba3af05488e3bfa105c42ecc8d7ee74d3e520e32c362051b8c123b9357876cd23e400e34171042538297f32b1903f40f2b854759c856abd89548093f WHIRLPOOL c28f5e12e2032f4b0c65acefbaf2100d25124c8425c0018d0a1f9160ac082fd6c1f171f2a11b530c7c8aaaa512f21d61f222ce292d792384fd0930b4c9af769b
diff --git a/dev-python/simpleeval/metadata.xml b/dev-python/simpleeval/metadata.xml
new file mode 100644
index 000000000000..235315bac19d
--- /dev/null
+++ b/dev-python/simpleeval/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple, safe single expression evaluator library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">simpleeval</remote-id>
+ <remote-id type="github">danthedeckie/simpleeval</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simpleeval/simpleeval-0.8.2.ebuild b/dev-python/simpleeval/simpleeval-0.8.2.ebuild
new file mode 100644
index 000000000000..12ddb70ac07b
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.8.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="README.rst"
diff --git a/dev-python/simpleeval/simpleeval-0.8.5.ebuild b/dev-python/simpleeval/simpleeval-0.8.5.ebuild
new file mode 100644
index 000000000000..7a8a0953b6f7
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.8.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ dev-python/setuptools"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test || die
+}