summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-16 10:40:04 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-16 11:19:20 +0100
commitd36c067e089f80ad0b844c3b8764c31132f51d88 (patch)
tree74c159718bfb5c0d2ad888c50472ed589b0054f0 /dev-python/simplejson
parentintel-sdp.eclass: Drop @CODE for DESCRIPTION (diff)
downloadgentoo-d36c067e089f80ad0b844c3b8764c31132f51d88.tar.gz
gentoo-d36c067e089f80ad0b844c3b8764c31132f51d88.tar.bz2
gentoo-d36c067e089f80ad0b844c3b8764c31132f51d88.zip
dev-python/simplejson: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.8.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 1fbe8389a424..7e1a4424ffd0 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,4 @@
DIST simplejson-3.7.2.tar.gz 74877 SHA256 8358ecc05541be4068109acf26a4ae89ba14450d20e92e0973d0d67bea3d7431 SHA512 5e2874c4d627035b3e205b5208b46beb172ac934742b0cb68f43f70aa2f401ec568c2b69fccdb1d870bf5196df0f6e37b790332a6e4d7969a296c8c104bdfe0b WHIRLPOOL 26f5e23250031d9b20b121a7110a1b623f32128721281b2554f2727f815b03b39b0680d21b41bb8729288f2774d38e92301bcf72188d054aa03497818edefdca
DIST simplejson-3.8.0.tar.gz 75875 SHA256 217e4797da3a9a4a9fbe6722e0db98070b8443a88212d7acdbd241a7668141d9 SHA512 c985a0f56170f78b6c6e8f0e4b4bf50f258c8f2639524f5b14d8e07b547e336acf96ac55cf562243fff06752ceba4a05f1e6dd43f6c918159a7b3640af0f0c1d WHIRLPOOL 368779f57bc1186d3b30ae80f74d0eca50709dfe6063d52c359d665eaacc9caa751fbbb9f4437e8bf8908f3569f85424632208d8f7c6146ebc8e8cc9c77b723d
DIST simplejson-3.8.1.tar.gz 76033 SHA256 428ac8f3219c78fb04ce05895d5dff9bd813c05a9a7922c53dc879cd32a12493 SHA512 9c135347a015f5fbb4373da61282230430320c89bc1114f7487eb632bccbe29a4b2c396d724c6c72af5c7df78f1676869a037be9d137b4f29f18e82a9eb2b1f5 WHIRLPOOL 8441ccaff4e4115d58461f528179c4fc25139b5f7f86cc85826798e392e664154468f1fa2471f18fc7bd518adf06a75b493218765ca4df022d92e6ee24552e38
+DIST simplejson-3.8.2.tar.gz 76578 SHA256 d58439c548433adcda98e695be53e526ba940a4b9c44fb9a05d92cd495cdd47f SHA512 041445bcee97e37361ed6270937fb4e74b6fc05988678da213ddc4f57f83134bfc933b0fb22101c387898bffac1b29d6eb78f03ec0853cf1086b155cee6ca309 WHIRLPOOL c6d32565925653050beb1939db6215ad910891a19ef721d6bc53b3d2beb50667f6201e5afc71e28c1644d18cdbdb6f2d53bfb5ca75feb9e129d01ed7fca035c1
diff --git a/dev-python/simplejson/simplejson-3.8.2.ebuild b/dev-python/simplejson/simplejson-3.8.2.ebuild
new file mode 100644
index 000000000000..41e1c8ef5c04
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson https://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}