summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-12-31 12:52:24 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-12-31 12:52:24 +0700
commit3b398adf009ea8d4face649a079261ed96e45895 (patch)
treeeef0742cb6a0488f5ab952ed0c503e142631227d /dev-python/sip
parentgnome-base/gnome-shell: Remove old (diff)
downloadgentoo-3b398adf009ea8d4face649a079261ed96e45895.tar.gz
gentoo-3b398adf009ea8d4face649a079261ed96e45895.tar.bz2
gentoo-3b398adf009ea8d4face649a079261ed96e45895.zip
dev-python/sip: bump to 4.19
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-4.19.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 0ec013b6f95b..dc68b0fe6085 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -2,3 +2,4 @@ DIST sip-4.16.2.tar.gz 793663 SHA256 a55a2324a46ab42e42ae57c52ef06583b17d25c9879
DIST sip-4.16.9.tar.gz 957858 SHA256 dbe173aa566e26ca0bb5bcbc1d30ef780f416267bb3b5df48149a737ea6b0555 SHA512 f9e7deac3462f71e809fce29aea4b7e7e3d1acb7600252178459cfb9e09d1543e9a189bdc66c946c9d11c4a6f3175a6d6b306481cadab70ed7f17f6e7c328ddc WHIRLPOOL f4cfcb5ecc945332683bdcbd6913b87fc975f8e268e02e6bdeaadebf578e40f1e94a3c76cdb1ea3890ec969d1454560d58df01ba4ad507d914a300076365ade0
DIST sip-4.18.1.tar.gz 992624 SHA256 9bce7a2dbf7f105bf68ad1bab58eebc0ce33087ec40396da756463f086ffa290 SHA512 c4277fa113bf5e28d8a19388f160456654e4ccbbc2adc1209677e95e1efad427ce641ef09875ec0a59e555578986671261dd4c3ac52c673b5803f188fc311222 WHIRLPOOL 6250081ffda585dda7c7728fe1253a1791ef63d4798d02c752e1c5b58837d2c55dd87306c83202be03f96bd644bd5b17b3b1e28b5c06b28bb8a69dd23da2ee09
DIST sip-4.18.tar.gz 991980 SHA256 f1dc5c81c07a9ad97edcd4a0af964a41e420024ba7ca165afd2b351efd249cb6 SHA512 365fb51b8c833ebc923b87a961fac83976b653ebcec8fe7ad1543ee5a406471eb9309c8efbee6662c7b622f36771cd3ac31ede10208f23d2531a45af906d383d WHIRLPOOL 3cf3516483e62ed26fca1de6bc90e58a2bd04d3d66214b0f62eb4338c2b7a8a595d46952ef86cd7fa61e50b160a06b484a7d4f5997be2f2a7714b1edabaef2a4
+DIST sip-4.19.tar.gz 1009474 SHA256 014bf55f653e0d8bcc582705ef4fbd61e0859a36e959ab46d8fa060cdf0b5e27 SHA512 0df39c2e004f5077439bdb4b4e463cdf0c141ce4e5dc65a957123801c122d6e3a30e238c0a77559d7202002a396d521be5517a8417b34c4092ab8319fa1d054c WHIRLPOOL b86f55750bc971d57420b24e1988f42e6974f7b222b1291c4def4ceb557c75e1c9cc15bbba27c7b99693fa0307aa171de6271acd7648cc6917cc0dc7b7486deb
diff --git a/dev-python/sip/sip-4.19.ebuild b/dev-python/sip/sip-4.19.ebuild
new file mode 100644
index 000000000000..001245674ae3
--- /dev/null
+++ b/dev-python/sip/sip-4.19.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.com/software/sip/intro https://pypi.python.org/pypi/SIP"
+SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
+
+# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
+SLOT="0/12"
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
+
+src_prepare() {
+ # Sub-slot sanity check
+ local sub_slot=${SLOT#*/}
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="$(python_get_sitedir)"
+ --incdir="$(python_get_includedir)"
+ $(usex debug --debug '')
+ AR="$(tc-getAR) cqs"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CFLAGS_RELEASE=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS_RELEASE=
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ LFLAGS="${LDFLAGS}"
+ LFLAGS_RELEASE=
+ RANLIB=
+ STRIP=
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake DESTDIR="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+ use doc && dodoc -r doc/html
+}