summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-07 11:55:21 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-07 11:55:21 -0500
commit8666a5c7e102946b1f8777e9a01bf4949d0513c5 (patch)
tree26c8b0e22718a049684159fd4971a9793a62b05b /dev-python/six
parentdev-python/six: Ensure PYTHON exists before calling python_get_sitedir (diff)
downloadgentoo-8666a5c7e102946b1f8777e9a01bf4949d0513c5.tar.gz
gentoo-8666a5c7e102946b1f8777e9a01bf4949d0513c5.tar.bz2
gentoo-8666a5c7e102946b1f8777e9a01bf4949d0513c5.zip
dev-python/six: Fix quoting and remove duplicate slashes
Package-Manager: portage-2.2.26_p10
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 810d8156f5fe..b5384b870c64 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -33,7 +33,8 @@ PATCHES=(
pkg_pretend() {
six_dir_check() {
type -p "${PYTHON}" > /dev/null || return 0
- local dir="${ROOT}"/$(python_get_sitedir)/six
+ local dir="${ROOT%/}$(python_get_sitedir)"/six
+ echo "${dir}"
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}
@@ -42,7 +43,7 @@ pkg_pretend() {
pkg_setup() {
six_dir_check() {
- local dir="${ROOT}"/$(python_get_sitedir)/six
+ local dir="${ROOT%/}$(python_get_sitedir)"/six
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}