summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 21:51:05 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 09:05:16 +0200
commitc9262291241db06affbf287a661f1a3accc685b6 (patch)
tree4b29c54e8f0329eca807d706e39cc441898cc41d /dev-python/six
parentdev-python/requests: Version Bump (diff)
downloadgentoo-c9262291241db06affbf287a661f1a3accc685b6.tar.gz
gentoo-c9262291241db06affbf287a661f1a3accc685b6.tar.bz2
gentoo-c9262291241db06affbf287a661f1a3accc685b6.zip
dev-python/six: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.10.0.ebuild40
-rw-r--r--dev-python/six/six-9999.ebuild2
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index db42ca028902..e8a200a4e3d0 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,4 @@
+DIST six-1.10.0.tar.gz 29630 SHA256 105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e WHIRLPOOL aad2fc7438b0df029bf477a783161dc169795c355be1281f1fe7aa4eb959eae5abf3bc96d097a221e0e5ad0b0494c29025bbe99bc28ff0c29ae1776e8691a70a
DIST six-1.3.0.tar.gz 17701 SHA256 d59793f9b255bd00de800b97f9a50cce4fc8a44c205f7defa5bb7d691d13b852 SHA512 e8974d4bf62325f98e301e68c237489ca39cfa9ed1066f1cdfa34e18d20d0baf788cb515e44f00f1c823f9f923d2b30f63443dbc5df8c934b1a69b8c68210130 WHIRLPOOL bd259a4e2cd0ae2629a8998a01641874266928d6fe3e65669198a9706cd4f90579902196680932b5c9207db1005376ae8b4cbc7b63f30afabe8993e719df9a5e
DIST six-1.6.1.tar.gz 24792 SHA256 d4392a7c8d91b005c002568a85faf617c67241c8cd8399cc395e8f1005aff80d SHA512 bd925295964696dc8632eb0b9d6632f25d4b461fefceb470d2bb537e98b0db9dddf9c2abb363657451b950572e91f1ab5973d12739781823f9b845abe5061057 WHIRLPOOL 54ee9309a0433231530962e64f19246cda75b36c191f6b567ccef4bb4c4cd631785d0641bc958b1cf360bc3eedcbc5bb268bc9ddf645b68c5c54bc80e184b3bc
DIST six-1.8.0.tar.gz 26925 SHA256 047bbbba41bac37c444c75ddfdf0573dd6e2f1fbd824e6247bb26fa7d8fa3830 SHA512 e705c0213396d1220f02f2c6f724ddb9d95eefc38459b6d9bc547be859303bd404969965416f7d1614d2eab416d647d0b53502414cdc46bcb597675cf509b9ff WHIRLPOOL 1a84ecd8635e93f104447b78a6beb577639a5eebef79af40fd8c8e9796ae35c1f49dea64546f46ec31e5589c86c4b36c9fc2e28226e0c9540aabd49ebcf7bf07
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
new file mode 100644
index 000000000000..49d12e07c2ce
--- /dev/null
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.9.0-mapping.patch
+ )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/ )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/six/six-9999.ebuild b/dev-python/six/six-9999.ebuild
index 19dd7371ad99..1807e5e4f34e 100644
--- a/dev-python/six/six-9999.ebuild
+++ b/dev-python/six/six-9999.ebuild
@@ -21,7 +21,7 @@ IUSE="doc test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
python_compile_all() {
use doc && emake -C documentation html