summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-23 15:05:26 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-23 15:34:02 -0400
commitdffa6b3a1727821ec1d76f51cd76fd57a9c02aa9 (patch)
tree748e356a065ce0b34a2428193f6aab36cbd3da1a /dev-python/six
parentsys-fs/e4rat: Fix compilation with gcc6 (#594046 by Peter Levine) (diff)
downloadgentoo-dffa6b3a1727821ec1d76f51cd76fd57a9c02aa9.tar.gz
gentoo-dffa6b3a1727821ec1d76f51cd76fd57a9c02aa9.tar.bz2
gentoo-dffa6b3a1727821ec1d76f51cd76fd57a9c02aa9.zip
dev-python/six: remove old
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.9.0-r1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index cc520844212f..810f4cc53156 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,2 +1 @@
DIST six-1.10.0.tar.gz 29630 SHA256 105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e WHIRLPOOL aad2fc7438b0df029bf477a783161dc169795c355be1281f1fe7aa4eb959eae5abf3bc96d097a221e0e5ad0b0494c29025bbe99bc28ff0c29ae1776e8691a70a
-DIST six-1.9.0.tar.gz 29127 SHA256 e24052411fc4fbd1f672635537c3fc2330d9481b18c0317695b46259512c91d5 SHA512 bcd94367a26c326ff9cc884e67cd705077366b6c091ad4ec805791f0ddc05452fe046c0ad843fbd530fa956ef240b951e69a7fedd41f5e7aaaabdc4761e987ea WHIRLPOOL a71ed4a8c7688cf2fee668ea203e767a2ad073797d1a4c651704d3e6ee9070b32cf43b89bace98fd07781af98016bbe2d9ec1b2b7d67de02912cfa30be65052f
diff --git a/dev-python/six/six-1.9.0-r1.ebuild b/dev-python/six/six-1.9.0-r1.ebuild
deleted file mode 100644
index 274a6cb4062d..000000000000
--- a/dev-python/six/six-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-DEPEND="
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/1.10.0-no-setuptools.patch
- "${FILESDIR}"/${PV}-mapping.patch
- "${FILESDIR}"/${P}-winreg.patch
-)
-
-python_compile_all() {
- use doc && emake -C documentation html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( documentation/_build/html/ )
- distutils-r1_python_install_all
-}
-
-pkg_preinst() {
- # Remove this in the next version bump
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- echo rm -r "${egginfo}"
- rm -r "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- cd / # Bug 585146
- python_foreach_impl _cleanup
-}