summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-16 13:27:39 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-16 13:27:39 +0200
commit2864b10d3da3d29d8c61524dc792ec359fffcbd0 (patch)
tree7227bad0db6c2c3c93d5128554190902ebd9b472 /dev-python/sphinx-testing
parentdev-python/httpretty: Add python3_6 (diff)
downloadgentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.tar.gz
gentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.tar.bz2
gentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.zip
dev-python/sphinx-testing: Initial version
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest1
-rw-r--r--dev-python/sphinx-testing/metadata.xml11
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
new file mode 100644
index 000000000000..e466695cc566
--- /dev/null
+++ b/dev-python/sphinx-testing/Manifest
@@ -0,0 +1 @@
+DIST sphinx-testing-0.7.2.tar.gz 11040 SHA256 9d30f93007620e137b33edf19f52a7225eab853546b7e588ef09d1342e821e94 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724 WHIRLPOOL 78ea240607f62c7c3ca98fc2ba0ec197b54aba6c0782d82c4da8fd695a37baae4d0b9bcd056b790dc610979a0031cce250d19c8360ffeb07463e4335af0df026
diff --git a/dev-python/sphinx-testing/metadata.xml b/dev-python/sphinx-testing/metadata.xml
new file mode 100644
index 000000000000..605d625f69e7
--- /dev/null
+++ b/dev-python/sphinx-testing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sphinx-doc/sphinx-testing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
new file mode 100644
index 000000000000..71a84edcf47b
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*') )"
+
+python_test() {
+ nosetests || die
+}