summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 09:01:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-17 09:57:11 +0100
commite27b4744ce6b72bf231798f46c0d80031064824a (patch)
tree06d4c148ecc802db39cc6f97e7e1779cb6f1fc44 /dev-python/statsd
parentdev-python/py-cpuinfo: New package, ebuild written by me (diff)
downloadgentoo-e27b4744ce6b72bf231798f46c0d80031064824a.tar.gz
gentoo-e27b4744ce6b72bf231798f46c0d80031064824a.tar.bz2
gentoo-e27b4744ce6b72bf231798f46c0d80031064824a.zip
dev-python/statsd: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/statsd')
-rw-r--r--dev-python/statsd/Manifest1
-rw-r--r--dev-python/statsd/metadata.xml15
-rw-r--r--dev-python/statsd/statsd-3.2.1.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/statsd/Manifest b/dev-python/statsd/Manifest
new file mode 100644
index 000000000000..b1d26e01f0b3
--- /dev/null
+++ b/dev-python/statsd/Manifest
@@ -0,0 +1 @@
+DIST statsd-3.2.1.tar.gz 166047 SHA256 3fa92bf0192af926f7a0d9be031fe3fd0fbaa1992d42cf2f07e68f76ac18288e SHA512 c5166fabcef2158aeb29b07b9bd1d241bc30847eb0e2c7694ee097b3a262e2590189ee10daecb368807002bd96fed16e749ca744b51b5e946d48fe2931a0d8e8 WHIRLPOOL 1ae98a9c16fdb7a1be8135c232c99d771e292dab7d87c12e6a989c18dad1c600c4ac2bb186a96dcdce49812fc26c30925ca30be3c2e85cb736797cb1c35c6571
diff --git a/dev-python/statsd/metadata.xml b/dev-python/statsd/metadata.xml
new file mode 100644
index 000000000000..5adf733e059e
--- /dev/null
+++ b/dev-python/statsd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">statsd</remote-id>
+ <maintainer status="unknown">
+ <email>james@mozilla.com</email>
+ <name>James Socol</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/statsd/statsd-3.2.1.ebuild b/dev-python/statsd/statsd-3.2.1.ebuild
new file mode 100644
index 000000000000..2f7ea238bcf3
--- /dev/null
+++ b/dev-python/statsd/statsd-3.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="https://github.com/jsocol/pystatsd http://pypi.python.org/pypi/statsd"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}