summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tabulate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest3
-rw-r--r--dev-python/tabulate/metadata.xml11
-rw-r--r--dev-python/tabulate/tabulate-0.7.2.ebuild35
-rw-r--r--dev-python/tabulate/tabulate-0.7.3.ebuild35
-rw-r--r--dev-python/tabulate/tabulate-0.7.5.ebuild35
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
new file mode 100644
index 000000000000..b0f127b6942a
--- /dev/null
+++ b/dev-python/tabulate/Manifest
@@ -0,0 +1,3 @@
+DIST tabulate-0.7.2.tar.gz 19792 SHA256 532ccab8d9e4659a5f016d84814df86cc04763785e9de2739e890d956dc82d8f SHA512 49cbaf26004032889743937615a6f27a0728016013d81a3a0dfea0d3b25904aed333e59e697fb5040a61d68dfa6c8f8e7c1dd0b0ac4b470f424a26e62bf0a5d8 WHIRLPOOL 30cf8386c5961e3c0674e1c4b490cc21789644d6ad37e0dd9cdb46608220a26fd377b2ed8c34522c7dd8284692287c713b4bed58b229541cfb7aecc5d74c9ca7
+DIST tabulate-0.7.3.tar.gz 22315 SHA256 8a59a61ed6ddfdb009f15917e0f006cc5842f9daa72c519593b7a095e645532a SHA512 1932627e50f00caa14b8a393dd005cf5cc096c80918c4f943526560c0409561e9f8063e4ca0610b1c7e9006119ba6f56294c3b256d1ba60c1c52ea7da62ad67b WHIRLPOOL 77f8794536ab4a72eb32708296f24c68889877228cc9d4735ec177cf5e82b0bdd17cd46854e2a3ebf84b7295b897b6c171a842faf22538f157b7b681e1124ef0
+DIST tabulate-0.7.5.tar.gz 29844 SHA256 9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e SHA512 dfc79e5fc2774520c117c4a2ee65ebe38f65430bda19697d443893a6eaad117de56c4b4c5157cdb8b09871c4eb452bc0b040b331602b6ab547b4326eb5c145eb WHIRLPOOL 719d507db5796960535c56e15f472130830715433f620bd92cb8c521a9ea58780286bf0f5f6fc32abe357cc185053d68505381e32b8e75c9334d5b5965ee85f2
diff --git a/dev-python/tabulate/metadata.xml b/dev-python/tabulate/metadata.xml
new file mode 100644
index 000000000000..e503ed4a5b7f
--- /dev/null
+++ b/dev-python/tabulate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">tabulate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tabulate/tabulate-0.7.2.ebuild b/dev-python/tabulate/tabulate-0.7.2.ebuild
new file mode 100644
index 000000000000..916d1514d585
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something:
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}
diff --git a/dev-python/tabulate/tabulate-0.7.3.ebuild b/dev-python/tabulate/tabulate-0.7.3.ebuild
new file mode 100644
index 000000000000..7776a856ad53
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something:
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}
diff --git a/dev-python/tabulate/tabulate-0.7.5.ebuild b/dev-python/tabulate/tabulate-0.7.5.ebuild
new file mode 100644
index 000000000000..7776a856ad53
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something:
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}