summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-02-21 19:29:40 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-21 19:29:40 +0100
commit06d25c7dd6203bf3def98603b0f77bd0bc58e7dd (patch)
tree1c39c4afb236de1cb66e8b5ffb782d22c1c2e77b /dev-python/tagpy
parentsys-auth/otpcalc: Version bump to 0.97.9 (diff)
downloadgentoo-06d25c7dd6203bf3def98603b0f77bd0bc58e7dd.tar.gz
gentoo-06d25c7dd6203bf3def98603b0f77bd0bc58e7dd.tar.bz2
gentoo-06d25c7dd6203bf3def98603b0f77bd0bc58e7dd.zip
dev-python/tagpy: Add python 3.9
* Also add testsuite Closes: https://bugs.gentoo.org/748924 Closes: https://bugs.gentoo.org/767991 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/tagpy-2018.1-r1.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/dev-python/tagpy/tagpy-2018.1-r1.ebuild b/dev-python/tagpy/tagpy-2018.1-r1.ebuild
index 35daa217ce97..56a858f2cc9c 100644
--- a/dev-python/tagpy/tagpy-2018.1-r1.ebuild
+++ b/dev-python/tagpy/tagpy-2018.1-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="Python Bindings for TagLib"
-HOMEPAGE="https://mathema.tician.de//software/tagpy
+HOMEPAGE="
+ https://mathema.tician.de//software/tagpy
https://pypi.org/project/tagpy/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -20,11 +20,12 @@ IUSE="examples"
RDEPEND="
>=dev-libs/boost-1.70:=[python,threads,${PYTHON_USEDEP}]
- >=media-libs/taglib-1.8
-"
+ >=media-libs/taglib-1.8"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-taglib-1.8.patch" )
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-taglib-1.8.patch )
python_prepare_all() {
cp "${FILESDIR}"/${P}-readme.rst README.rst || die
@@ -34,15 +35,20 @@ python_prepare_all() {
python_configure() {
local boostpy_ver="${EPYTHON#python}"
- "${PYTHON}" configure.py \
- --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ "${EPYTHON}" configure.py \
+ --taglib-inc-dir="${ESYSROOT}"/usr/include/taglib \
--boost-python-libname="boost_python${boostpy_ver/\.}"
}
+python_test() {
+ cd test || die
+ "${EPYTHON}" *.py || die "Testsuite failed under ${EPYTHON}"
+}
+
python_install_all() {
if use examples; then
docinto examples
- dodoc -r test/*
+ dodoc -r test/.
fi
distutils-r1_python_install_all