summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-18 21:31:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-18 21:32:47 +0200
commit48c4a383750402df32b41e9ca2aad00b597a3ada (patch)
tree24d2787832c121007df9788fa1c0588d8e7614b7 /dev-python/tagpy
parentdev-python/tagpy: python3_8 support (diff)
downloadgentoo-48c4a383750402df32b41e9ca2aad00b597a3ada.tar.gz
gentoo-48c4a383750402df32b41e9ca2aad00b597a3ada.tar.bz2
gentoo-48c4a383750402df32b41e9ca2aad00b597a3ada.zip
dev-python/tagpy: Drop 2018.1 (r0)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/tagpy-2018.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/tagpy/tagpy-2018.1.ebuild b/dev-python/tagpy/tagpy-2018.1.ebuild
deleted file mode 100644
index af8120b279b1..000000000000
--- a/dev-python/tagpy/tagpy-2018.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Python Bindings for TagLib"
-HOMEPAGE="https://mathema.tician.de//software/tagpy
- https://pypi.org/project/tagpy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE="examples"
-
-RDEPEND="
- dev-libs/boost:=[python,threads,${PYTHON_USEDEP}]
- >=media-libs/taglib-1.8
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}/${P}-taglib-1.8.patch" )
-
-python_prepare_all() {
- cp "${FILESDIR}"/${P}-readme.rst README.rst || die
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- local boostpy_ver="${EPYTHON#python}"
- if has_version ">=dev-libs/boost-1.70"; then
- boostpy_ver="${boostpy_ver/\.}"
- else
- boostpy_ver="-${boostpy_ver}"
- fi
-
- "${PYTHON}" configure.py \
- --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
- --boost-python-libname="boost_python${boostpy_ver}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r test/*
- fi
-
- distutils-r1_python_install_all
-}