summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 15:06:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:24 +0100
commit64f9952699b76d709bba2896efc87fe67c329c05 (patch)
treef1663fb1578ff4c23d45bc994e212edf5ed64e70 /dev-python/tagpy
parentdev-python/csvkit: Bump to 1.1.0 (diff)
downloadgentoo-64f9952699b76d709bba2896efc87fe67c329c05.tar.gz
gentoo-64f9952699b76d709bba2896efc87fe67c329c05.tar.bz2
gentoo-64f9952699b76d709bba2896efc87fe67c329c05.zip
dev-python/tagpy: Bump to 2022.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/Manifest1
-rw-r--r--dev-python/tagpy/metadata.xml1
-rw-r--r--dev-python/tagpy/tagpy-2022.1.ebuild33
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tagpy/Manifest b/dev-python/tagpy/Manifest
index e78e624b4af7..a9b938d0bf45 100644
--- a/dev-python/tagpy/Manifest
+++ b/dev-python/tagpy/Manifest
@@ -1 +1,2 @@
DIST tagpy-2018.1.tar.gz 145501 BLAKE2B acdda6789dae000ba2f664e4a5582f6218f312bed20ec81c4ea54f358bec70d41aceed6704f392a7a32c39d263da81f9c832922942fa179e1865e423dcf28bcf SHA512 2010baa919adadc9fc231deeb093953622ec54c8b6011e2d6a3489b086032de0a71cc26f42439435f26bd7a1ff069e3944dafc61217abe6ea5e81b01b9d18c50
+DIST tagpy-2022.1.gh.tar.gz 198744 BLAKE2B 1a0722017ae532444cf97171c04964453bdb6c427a49bace4ad9fe3a3be9be7f0903a9ae3fb8dbf0c8450112ed5f83677044c6b2546dddec3550d8251cef4cff SHA512 d740bf17abe6a2a7cd7fe037c024c8361d49d2ec4e8d03dbdc27c9ec273696b0a41d087a7159692e9b849e807af493f68239562da01d5191bee95060b32aabda
diff --git a/dev-python/tagpy/metadata.xml b/dev-python/tagpy/metadata.xml
index 71d1be34fe2f..ac2570686aa0 100644
--- a/dev-python/tagpy/metadata.xml
+++ b/dev-python/tagpy/metadata.xml
@@ -9,6 +9,7 @@
Wheeler's TagLib. It builds upon Boost.Python, a wrapper generation
library which is part of the Boost set of C++ libraries.</longdescription>
<upstream>
+ <remote-id type="github">palfrey/tagpy</remote-id>
<remote-id type="pypi">tagpy</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/tagpy/tagpy-2022.1.ebuild b/dev-python/tagpy/tagpy-2022.1.ebuild
new file mode 100644
index 000000000000..6839fa9b82cd
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2022.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="
+ https://github.com/palfrey/tagpy/
+ https://pypi.org/project/tagpy/
+"
+SRC_URI="
+ https://github.com/palfrey/tagpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ >=media-libs/taglib-1.8
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest