summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 07:43:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 08:06:21 +0200
commit064c9d9ceb4ce4957e4dbc11224d2fe27f6cd46f (patch)
treedaba4b2c5e6a717c5ab51a80a7f64c8be41b72a6 /dev-python/tblib
parentdev-python/pyglet: Bump to 2.0.8 (diff)
downloadgentoo-064c9d9ceb4ce4957e4dbc11224d2fe27f6cd46f.tar.gz
gentoo-064c9d9ceb4ce4957e4dbc11224d2fe27f6cd46f.tar.bz2
gentoo-064c9d9ceb4ce4957e4dbc11224d2fe27f6cd46f.zip
dev-python/tblib: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tblib')
-rw-r--r--dev-python/tblib/Manifest1
-rw-r--r--dev-python/tblib/tblib-2.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tblib/Manifest b/dev-python/tblib/Manifest
index ba48320ce09b..a5b0740e8b7e 100644
--- a/dev-python/tblib/Manifest
+++ b/dev-python/tblib/Manifest
@@ -1 +1,2 @@
DIST tblib-1.7.0.tar.gz 33074 BLAKE2B e05b94b9a36efde4d3fe76e9b72502674554e84e49916ea585de4f6cf9e898d1544535b1a8935fe15ffc100fcbf2b5d4f9edfdcf0ce5c86d479f2f412d3ea83f SHA512 10dcff18a1da386d9dd6bae35608f4a2d3bc8f87c15fcf49d886f98d95a6defd348ef0dc5637e03f4c553a933a0ecb4c215cf15b1e78fca58fea10052f9fb4e9
+DIST tblib-2.0.0.tar.gz 28695 BLAKE2B 7c7cb584e5a5f03d403253d94c051d7ffd988b2320b095376184b479f30674989cecd39ca43fd269884e73ad97e6f9424a29dec9f1338e002ebe1adfc31a52d4 SHA512 740e7b02c4ae61b12ed1c0c3623c5c2dd142aaa24989e57d67ceed4894212bc18d51f0ab0a97953f1a0e16b30ef992ecee3730038e8b8fd4a3bc437d4a1a92b0
diff --git a/dev-python/tblib/tblib-2.0.0.ebuild b/dev-python/tblib/tblib-2.0.0.ebuild
new file mode 100644
index 000000000000..9a3df624eeef
--- /dev/null
+++ b/dev-python/tblib/tblib-2.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Traceback fiddling library for Python"
+HOMEPAGE="
+ https://github.com/ionelmc/python-tblib/
+ https://pypi.org/project/tblib/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}