summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/testify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/Manifest2
-rw-r--r--dev-python/testify/metadata.xml9
-rw-r--r--dev-python/testify/testify-0.5.7.ebuild45
-rw-r--r--dev-python/testify/testify-0.7.2.ebuild53
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
new file mode 100644
index 000000000000..884d8e0516c8
--- /dev/null
+++ b/dev-python/testify/Manifest
@@ -0,0 +1,2 @@
+DIST testify-0.5.7.tar.gz 166954 SHA256 153796d3b20b2d8554e52af26a8c891e6f02dfd6cc7be29f9241dad244cff044 SHA512 410ac412306c11bba992b882624fcacdbff00e2865cd986c560d8b50ea8dff0ead8603b18f40414d8dbbe1f3ab9426e0f61170dc450927f6d2282e389800ff21 WHIRLPOOL 2cc958efea71bd475c698cee36e4f1bdb7197c8cb54c38efbf66927d5abc60e769a8995ae7fb4107fab8b74e4b05afcaf16e5c0aec9db3471ddbd771bafa3adf
+DIST testify-0.7.2.tar.gz 102858 SHA256 7c209530fbb67344fe8985012056116d7d8eadd6ff126f91c93aa19208fd3ec9 SHA512 4b470aabe1ada88ddaf89145c77dbc5c2d000c8e0fab431535c08b4ff05a04c12f215d4c05d678ba718fdf3295be74fef23041d01d3c05e0b9e2c43c5ab0ed1e WHIRLPOOL 37ff8d7068ba4569215e3df440186ef3149a5fde0e12ec5efefc5b666adf2958b11f4db18995b46536cbf504dadec48f00b5f38e524ae09eb815c8170b8cf669
diff --git a/dev-python/testify/metadata.xml b/dev-python/testify/metadata.xml
new file mode 100644
index 000000000000..24da195dd289
--- /dev/null
+++ b/dev-python/testify/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">testify</remote-id>
+ <remote-id type="github">Yelp/testify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testify/testify-0.5.7.ebuild b/dev-python/testify/testify-0.5.7.ebuild
new file mode 100644
index 000000000000..2e5e730293dd
--- /dev/null
+++ b/dev-python/testify/testify-0.5.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Still appears to no support >=py3.3
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+ # Correct use of local importing in test_ file
+ sed -e s':from .test_runner_subdir:from test.test_runner_subdir:' \
+ -e s':from .test_runner_bucketing:from test.test_runner_bucketing:' \
+ -i test/test_runner_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH}:${S}"
+ for test in test/*_test.py;
+ do
+ "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
+ done
+}
diff --git a/dev-python/testify/testify-0.7.2.ebuild b/dev-python/testify/testify-0.7.2.ebuild
new file mode 100644
index 000000000000..ed7ef7659ce0
--- /dev/null
+++ b/dev-python/testify/testify-0.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Still appears to not support >=py3.3
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+
+ # Correct use of local importing in pertinent test_ files
+ sed -e s':from .test:from test:' \
+ -i test/test_runner_test.py || die
+
+ sed -e s':from .discovery:from discovery:' \
+ -i test/test_runner_server_test.py || die
+
+ sed -e s':from .test:from test:' \
+ -i test/test_runner_server_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
+ einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
+ for test in test/test_*_test.py;
+ do
+ "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
+ done
+}