summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:36:07 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:36:07 +0100
commit1fb45205d6631eacbab9163a0b0fd5c86cdc1509 (patch)
tree20a86621b5abbd55e440083f8bb693646ac3a9d5 /dev-python/testpath
parentdev-python/jupyter: Import from science overlay (diff)
downloadgentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.tar.gz
gentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.tar.bz2
gentoo-1fb45205d6631eacbab9163a0b0fd5c86cdc1509.zip
dev-python/testpath: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/files/testpath-0.2-setup.py.patch28
-rw-r--r--dev-python/testpath/metadata.xml14
-rw-r--r--dev-python/testpath/testpath-0.2.ebuild55
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
new file mode 100644
index 000000000000..665ec38706da
--- /dev/null
+++ b/dev-python/testpath/Manifest
@@ -0,0 +1 @@
+DIST testpath-0.2.tar.gz 13732 SHA256 a5388cc7c8370b1f11298c1d513b3d2b9e2f390607a7c39963e6e3ba9f1b7012 SHA512 cc211bdc8f31ff4c286324e37bbce7fd84e19447d9735f396ce67f7568dd1d133be732c1fd7a08928c94566279d0f293a0caeed6a58ae6cd3dc293035fe164ea WHIRLPOOL 6b87b1c5ba590e6b19968e823dee22d7bbe0411124c1290593eb5efd78b5af06c51853d3359f339c4ca60b2842c409a1fcd0ff45c59f2e7e07f557534d78fcaa
diff --git a/dev-python/testpath/files/testpath-0.2-setup.py.patch b/dev-python/testpath/files/testpath-0.2-setup.py.patch
new file mode 100644
index 000000000000..065e8e5e85ad
--- /dev/null
+++ b/dev-python/testpath/files/testpath-0.2-setup.py.patch
@@ -0,0 +1,28 @@
+Patch to bring back setup.py from
+https://github.com/jupyter/testpath/blob/086bd1bd1ec7da1b3dacfed1705c0c99fae231b3/setup.py
+--- /dev/null
++++ setup.py
+@@ -0,0 +1,22 @@
++from distutils.core import setup
++
++with open("README.rst", "r") as f:
++ readme = f.read()
++
++setup(name='testpath',
++ version='0.1',
++ description='Test utilities for code working with files and commands',
++ long_description = readme,
++ author='Thomas Kluyver',
++ author_email='thomas@kluyver.me.uk',
++ url='https://github.com/takluyver/testpath',
++ packages=['testpath'],
++ classifiers=[
++ 'Intended Audience :: Developers',
++ 'License :: OSI Approved :: MIT License',
++ 'Programming Language :: Python',
++ 'Programming Language :: Python :: 2',
++ 'Programming Language :: Python :: 3',
++ 'Topic :: Software Development :: Testing',
++ ]
++)
+\ No newline at end of file
diff --git a/dev-python/testpath/metadata.xml b/dev-python/testpath/metadata.xml
new file mode 100644
index 000000000000..4db1c842b5ba
--- /dev/null
+++ b/dev-python/testpath/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Testpath is a collection of utilities for Python code working with
+ files and commands. It contains functions to check things on the
+ filesystem, and tools for mocking system commands and recording
+ calls to those.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/testpath</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testpath/testpath-0.2.ebuild b/dev-python/testpath/testpath-0.2.ebuild
new file mode 100644
index 000000000000..a3ee76529f4a
--- /dev/null
+++ b/dev-python/testpath/testpath-0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}"-setup.py.patch
+ )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+ }
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}