summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/testtools
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/testtools-1.8.0-r1.ebuild46
-rw-r--r--dev-python/testtools/testtools-1.8.0.ebuild2
2 files changed, 1 insertions, 47 deletions
diff --git a/dev-python/testtools/testtools-1.8.0-r1.ebuild b/dev-python/testtools/testtools-1.8.0-r1.ebuild
deleted file mode 100644
index 6243aebf7d9d..000000000000
--- a/dev-python/testtools/testtools-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="https://github.com/testing-cabal/testtools"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND="
- dev-python/extras[${PYTHON_USEDEP}]
- dev-python/mimeparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/testtools/testtools-1.8.0.ebuild b/dev-python/testtools/testtools-1.8.0.ebuild
index d2f5d2046439..e928f1b6f8b3 100644
--- a/dev-python/testtools/testtools-1.8.0.ebuild
+++ b/dev-python/testtools/testtools-1.8.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1