summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-06-08 11:13:43 +0200
committerFabian Groffen <grobian@gentoo.org>2018-06-08 11:16:31 +0200
commit940d780126118dce135a96d91795ecb48a402fda (patch)
treed2e6b9a21a22b1a77464fe044217807cfef44498 /dev-python/thrift
parentdev-python/PyContracts: mark s390 stable (diff)
downloadgentoo-940d780126118dce135a96d91795ecb48a402fda.tar.gz
gentoo-940d780126118dce135a96d91795ecb48a402fda.tar.bz2
gentoo-940d780126118dce135a96d91795ecb48a402fda.zip
dev-python/thrift: initial ebuild by me
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/Manifest1
-rw-r--r--dev-python/thrift/metadata.xml11
-rw-r--r--dev-python/thrift/thrift-0.11.0.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
new file mode 100644
index 000000000000..1294d7e40874
--- /dev/null
+++ b/dev-python/thrift/Manifest
@@ -0,0 +1 @@
+DIST thrift-0.11.0.tar.gz 52467 BLAKE2B 72dca118476dc5d618f6434614e5d72c6f496088731de9b62fcf47e76dcf707a171721df2aa4c87fdcf90670b8fd11c3a1cdb2b090b78683a3f4a204ef8121cb SHA512 cba59eef2841fa008a19cd36b322491b67d711698205d6671c76e38a3de2b330db8aa54516de8cdd4020dc795e67ed55913df53466f5dbf07d38fed2d10f9349
diff --git a/dev-python/thrift/metadata.xml b/dev-python/thrift/metadata.xml
new file mode 100644
index 000000000000..78b29df5c479
--- /dev/null
+++ b/dev-python/thrift/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">thrift</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/thrift/thrift-0.11.0.ebuild b/dev-python/thrift/thrift-0.11.0.ebuild
new file mode 100644
index 000000000000..bbc8f37a7dd5
--- /dev/null
+++ b/dev-python/thrift/thrift-0.11.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://thrift.apache.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"