summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-17 21:20:49 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-17 22:51:10 +0200
commit25999628212bf5d4370403336d7bb48fec14a0ef (patch)
tree7ab6f2a1e0bea806c0e2cdcd1430e2f331773567 /dev-python/timelib
parentdev-python/pyprof2calltree: Bump to 1.4.0 (diff)
downloadgentoo-25999628212bf5d4370403336d7bb48fec14a0ef.tar.gz
gentoo-25999628212bf5d4370403336d7bb48fec14a0ef.tar.bz2
gentoo-25999628212bf5d4370403336d7bb48fec14a0ef.zip
dev-python/timelib: Enable tests
Diffstat (limited to 'dev-python/timelib')
-rw-r--r--dev-python/timelib/Manifest2
-rw-r--r--dev-python/timelib/timelib-0.2.4-r1.ebuild19
2 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/timelib/Manifest b/dev-python/timelib/Manifest
index a0da5d42edd9..be077baf33e2 100644
--- a/dev-python/timelib/Manifest
+++ b/dev-python/timelib/Manifest
@@ -1 +1 @@
-DIST timelib-0.2.4.zip 281070 SHA256 49142233bdb5971d64a41e05a1f80a408a02be0dc7d9f8c99e7bdd0613ba81cb SHA512 871683756318f8896592e154a6949e6c96f9b9177ecd8694db2a48b16104cf35d11f550355a4723a097e9f17e3b7020d09a23916bd55a3dd463c22bed68991af WHIRLPOOL 941e3bccb1fba22eb54530c111ed0cbad136481e1e4f9c7107ae82625452b3534ad0b218b08eaf542efa159bc5df3afd49346cbc4fa297471998bd4412d3154b
+DIST timelib-0.2.4.tar.gz 295951 SHA256 7e6e5a103ce0447f9f91a56fd5d9cf54a1e5cece722b52e53d1b0bb9413248c2 SHA512 b19ef411f7a6d4f9e43e4de2a4c57f1f430b5c16ec88f7c3f72e8a2f6950a2e94c1ce3792203ba3add07994d1a8eaec4172aa09315b39df4494430e30ebd880b WHIRLPOOL 14ca47e9595117df0a45704daaf4d71721aa4ad9a5b06e006da1e71f37a76b6b04911187729206127608ca3d4ce7d6070735e60ccff4a4ca4549ea41b18f83aa
diff --git a/dev-python/timelib/timelib-0.2.4-r1.ebuild b/dev-python/timelib/timelib-0.2.4-r1.ebuild
index 2b2634b03fff..e5051a962611 100644
--- a/dev-python/timelib/timelib-0.2.4-r1.ebuild
+++ b/dev-python/timelib/timelib-0.2.4-r1.ebuild
@@ -2,19 +2,24 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
DESCRIPTION="parse english textual date descriptions"
-HOMEPAGE="https://pypi.python.org/pypi/timelib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+HOMEPAGE="https://github.com/pediapress/timelib https://pypi.python.org/pypi/timelib"
+# pypi zipball lacks tests; also it's .zip
+SRC_URI="https://github.com/pediapress/timelib/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="PHP-3.01 ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="test"
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}