summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-27 17:43:07 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-27 17:47:20 +0200
commit46610fb45234587374ebd1b64359a324766ce2d7 (patch)
tree4a1040fc1016fa3ebfdbdb341a8d9576677114fe /dev-python/urwidtrees
parentdev-python/pudb: enable py3.11 (diff)
downloadgentoo-46610fb45234587374ebd1b64359a324766ce2d7.tar.gz
gentoo-46610fb45234587374ebd1b64359a324766ce2d7.tar.bz2
gentoo-46610fb45234587374ebd1b64359a324766ce2d7.zip
dev-python/urwidtrees: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/urwidtrees')
-rw-r--r--dev-python/urwidtrees/Manifest1
-rw-r--r--dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/urwidtrees/Manifest b/dev-python/urwidtrees/Manifest
index 06c265e656c3..b90fcd2e57c5 100644
--- a/dev-python/urwidtrees/Manifest
+++ b/dev-python/urwidtrees/Manifest
@@ -1 +1,2 @@
+DIST urwidtrees-1.0.3.gh.tar.gz 292930 BLAKE2B 91487debf4878fb58cf2505366a4762a4c755b53eaac86e3ac912d2972c66442828e152749f34e73ade10fd1b912054e4047900e0b54b960629909c1b03e2270 SHA512 f7d69d359ba24345a694659fd9432335679f4b505a5c0e33baf9fc0c068935148c393aff8e11cd5f2c12aa26884aa37ba86e9b3a763472e382d73dd57fd32cd6
DIST urwidtrees-1.0.3.tar.gz 292930 BLAKE2B 91487debf4878fb58cf2505366a4762a4c755b53eaac86e3ac912d2972c66442828e152749f34e73ade10fd1b912054e4047900e0b54b960629909c1b03e2270 SHA512 f7d69d359ba24345a694659fd9432335679f4b505a5c0e33baf9fc0c068935148c393aff8e11cd5f2c12aa26884aa37ba86e9b3a763472e382d73dd57fd32cd6
diff --git a/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild b/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..fc66149847f8
--- /dev/null
+++ b/dev-python/urwidtrees/urwidtrees-1.0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tree widgets for urwid"
+HOMEPAGE="https://github.com/pazz/urwidtrees"
+SRC_URI="
+ https://github.com/pazz/urwidtrees/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-mock-dep.patch #770391
+)
+
+distutils_enable_sphinx docs/source
+
+src_prepare() {
+ find -name '*.py' -exec \
+ sed -i -e '1i# -*- coding: utf-8 -*-' {} + || die
+
+ distutils-r1_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}" || die
+ done
+}