summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/utidylib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest1
-rw-r--r--dev-python/utidylib/files/utidylib-0.2-fix_tests.patch48
-rw-r--r--dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch11
-rw-r--r--dev-python/utidylib/metadata.xml5
-rw-r--r--dev-python/utidylib/utidylib-0.2-r2.ebuild52
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
new file mode 100644
index 000000000000..5b63101a758c
--- /dev/null
+++ b/dev-python/utidylib/Manifest
@@ -0,0 +1 @@
+DIST uTidylib-0.2.zip 17575 SHA256 0385b29b0e636fa1cc6eb86ecb5428cf399f9474c8f343af038afce59720a333 SHA512 02f6611f1c7dd42db96012f7067ada8ccd841532744a569492a2f1c0524a3f1777b8f997a716b9bb18f69f31cb922dc89328d0bd284830620a930a038b303893 WHIRLPOOL 7d1509c36dccf8d7bd22f82d5a6cd95e8b7e422fb6aeab49e7316aaa98e18f771d9c7140897086da61d03b0df5fb3d4291c0b49acfbf8a8633498a837fbc2c2d
diff --git a/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
new file mode 100644
index 000000000000..b55a15119ba4
--- /dev/null
+++ b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
@@ -0,0 +1,48 @@
+diff -uNr uTidylib-0.2.orig/tidy/test_tidy.py uTidylib-0.2/tidy/test_tidy.py
+--- uTidylib-0.2.orig/tidy/test_tidy.py 2004-02-24 08:53:52.000000000 +0000
++++ uTidylib-0.2/tidy/test_tidy.py 2009-07-25 15:50:56.000000000 +0000
+@@ -4,6 +4,10 @@
+
+ class TidyTestCase(unittest.TestCase):
+ def __init__(self, *args, **kwargs):
++ super(unittest.TestCase, self).__init__(*args, **kwargs)
++ self._shared = False
++ self._parents = []
++
+ foo = u'''<html>
+ <h1>woot</h1>
+ <hr>
+@@ -13,13 +17,13 @@
+ </body>
+ </html>
+ '''.encode('utf8')
+- file('foo.htm', 'w').write(foo)
++ file('foo.htm', 'w').write(foo)
+ self.input1 = "<html><script>1>2</script>"
+ self.input2 = "<html>\n" + "<p>asdkfjhasldkfjhsldjas\n" * 100
+ def defaultDocs(self):
+ doc1 = tidy.parseString(self.input1)
+ doc2 = tidy.parseString(self.input2)
+- doc3 = tidy.parse("foo.htm")
++ doc3 = tidy.parse("../foo.htm")
+ doc4 = tidy.parse("bar.htm") # doesn't exist
+ return (doc1, doc2, doc3, doc4)
+ def test_badOptions(self):
+@@ -33,7 +37,7 @@
+ self.fail("Invalid option %s should have raised an error" %
+ repr(dct))
+ def test_encodings(self):
+- foo = file('foo.htm').read().decode('utf8').encode('ascii',
++ foo = file('../foo.htm').read().decode('utf8').encode('ascii',
+ 'xmlcharrefreplace')
+ doc1u = tidy.parseString(foo, input_encoding='ascii',
+ output_encoding='latin1')
+@@ -58,7 +62,7 @@
+ ## self.failIf(len(doc2.errors)>1) # FIXME - tidylib doesn't
+ ## # support this?
+ self.failUnless(str(doc2).find('\n')<0)
+- doc3 = tidy.parse('foo.htm', char_encoding='utf8',
++ doc3 = tidy.parse('../foo.htm', char_encoding='utf8',
+ alt_text='foo')
+ self.failUnless(str(doc3).find('alt="foo"')>=0)
+ self.failUnless(str(doc3).find('\xc3\xa9')>=0)
diff --git a/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch b/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch
new file mode 100644
index 000000000000..761c4947dfa8
--- /dev/null
+++ b/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch
@@ -0,0 +1,11 @@
+--- uTidylib-0.2-orig/setup.py 2005-12-01 00:48:14.000000000 +0100
++++ uTidylib-0.2/setup.py 2005-12-01 01:10:33.000000000 +0100
+@@ -54,7 +54,7 @@
+
+
+ setup_data = dict(packages=['tidy', ],
+- data_files=data_files,
++# data_files=data_files,
+ cmdclass=dict(install_data=install_data_utidylib,
+ bdist_wininst=bdist_wininst_utidylib,
+ install=install_utidylib,
diff --git a/dev-python/utidylib/metadata.xml b/dev-python/utidylib/metadata.xml
new file mode 100644
index 000000000000..ee7e8b2450a8
--- /dev/null
+++ b/dev-python/utidylib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/utidylib/utidylib-0.2-r2.ebuild b/dev-python/utidylib/utidylib-0.2-r2.ebuild
new file mode 100644
index 000000000000..82db8e4a70b5
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="uTidylib-${PV}"
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="http://sourceforge.net/projects/utidylib/"
+SRC_URI="mirror://berlios/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc test"
+
+RDEPEND="app-text/htmltidy"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
+ test? ( dev-python/twisted-core[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-no-docs-in-site-packages.patch"
+ "${FILESDIR}/${P}-fix_tests.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" gendoc.py || die
+ fi
+}
+
+python_test() {
+ trial tidy || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( apidoc/. )
+ distutils-r1_python_install_all
+}