summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-03 09:37:26 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-03 11:17:40 +0100
commit74fec04202a43f31037db1928f758e2279d13ed1 (patch)
tree0c3b5c377a52775bfb62fd0088822d971d947886 /dev-python/wrapt
parentdev-python/lazy-object-proxy: New package, ebuild written by me (diff)
downloadgentoo-74fec04202a43f31037db1928f758e2279d13ed1.tar.gz
gentoo-74fec04202a43f31037db1928f758e2279d13ed1.tar.bz2
gentoo-74fec04202a43f31037db1928f758e2279d13ed1.zip
dev-python/wrapt: Clean old
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.10.4.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 2d0bce46be19..c02f69f8695e 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,2 +1 @@
-DIST wrapt-1.10.4.tar.gz 102325 SHA256 c77f39270a9438a9429f6b2330e44ab6105aa760bbe00402765bac4dc51925d2 SHA512 759c43d18b2538912b30930a9ac192ba53921d5f353da07587e0ebb5236b255c87d1eb216a122b4455e16ed4973b39402f7057adfaf83775515d80b944c691af WHIRLPOOL 753ad039bc92ae9f2e785f57b21f9323f137bcefda8999decbac1c7adf85a9b0c7f00b147c62f4da1616b509423d54c9f2c6fa4d4ccf15b708d6fc13b0f48153
DIST wrapt-1.10.5.tar.gz 119157 SHA256 4fd82193b23f60e1a39f3e10c81143c1e29e26cd5fc9afe1a7dc0f5e4b4a67d7 SHA512 450b32eea67774081d23c0e020ed7eea3c8ac458925a16cd606a4f95ee5b7631bda5ff00ceb914e9ccc28a5e0a7302534b6711bb23d637c77327a8a9d228cb55 WHIRLPOOL 7cfa9477f525e60f16a7b1689ba43b327192837bea34e96977442b9cd143a63fafdfa7d0b3895c93052b0e6f426e76fa439b155ee4e481dd5e922c529676691c
diff --git a/dev-python/wrapt/wrapt-1.10.4.ebuild b/dev-python/wrapt/wrapt-1.10.4.ebuild
deleted file mode 100644
index 2fd4fc88f600..000000000000
--- a/dev-python/wrapt/wrapt-1.10.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Module for decorators, wrappers and monkey patching."
-HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
-SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
-"
-RDEPEND=""
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- local WRAPT_EXTENSIONS=true
-
- distutils-r1_python_compile
-}
-
-python_test() {
- py.test || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}