summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:32:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:54 +0200
commit179bf53a31cbb3169b2b0bb507f3a9e284f18e59 (patch)
tree23236f9646d3a10f6253fdb6753b94c58b6ab18e /dev-ros/base_local_planner
parentdev-ros/amcl: Bump to 1.17.0. (diff)
downloadgentoo-179bf53a31cbb3169b2b0bb507f3a9e284f18e59.tar.gz
gentoo-179bf53a31cbb3169b2b0bb507f3a9e284f18e59.tar.bz2
gentoo-179bf53a31cbb3169b2b0bb507f3a9e284f18e59.zip
dev-ros/base_local_planner: Bump to 1.17.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/base_local_planner')
-rw-r--r--dev-ros/base_local_planner/Manifest1
-rw-r--r--dev-ros/base_local_planner/base_local_planner-1.17.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/base_local_planner/Manifest b/dev-ros/base_local_planner/Manifest
index 1d8b6b730cb2..b2b347be7016 100644
--- a/dev-ros/base_local_planner/Manifest
+++ b/dev-ros/base_local_planner/Manifest
@@ -2,3 +2,4 @@ DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e
DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
DIST navigation-1.16.3.tar.gz 342459 BLAKE2B 736414787adee9c7511b0d90276395d33b9b52207d55ddd53836c9d77cb6809bf1946443878ad83e4461d0febf05b616b93ec0a18b34ed402323eb9bbb100861 SHA512 2eddb27fd3eff143674cc518be520e6df4d24a965689441f710105977f4bbe307736df5e6303319dde99362187091ea4f90eaec9da5a4bc678250410af174a71
DIST navigation-1.16.6.tar.gz 346529 BLAKE2B ed2d7ddd0ca9525f0ae22711d65fc2ede5f3046fd320e5016b93505616c4d476d65128695ff8830c4fa0b8dbdc276a1ec5951fdb4d0516f4d5f70897e4759f31 SHA512 c6bc3db39457c6bccba7ee2646504c4e1c91840a3297bdb9b92b28d93c608c0de113eb92527d4f499232de628d5b49816ec42522043500b20fb04056e2a7c97f
+DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
diff --git a/dev-ros/base_local_planner/base_local_planner-1.17.0.ebuild b/dev-ros/base_local_planner/base_local_planner-1.17.0.ebuild
new file mode 100644
index 000000000000..2b56b9d24ec5
--- /dev/null
+++ b/dev-ros/base_local_planner/base_local_planner-1.17.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/nav_core-1.16
+ dev-ros/pluginlib
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/voxel_grid
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_USEDEP}] )
+"