summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:38:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:38:33 +0200
commitaba19139adcd3f8557d6d3d82d71f1ff84dbef47 (patch)
tree1a2b82c8e57d997fdb5b1398d313fdef265c8fa0 /dev-ros
parentdev-ros/controller_interface: Initial import. Ebuild by me. (diff)
downloadgentoo-aba19139adcd3f8557d6d3d82d71f1ff84dbef47.tar.gz
gentoo-aba19139adcd3f8557d6d3d82d71f1ff84dbef47.tar.bz2
gentoo-aba19139adcd3f8557d6d3d82d71f1ff84dbef47.zip
dev-ros/realtime_tools: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/realtime_tools/Manifest1
-rw-r--r--dev-ros/realtime_tools/metadata.xml5
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.9.1.ebuild22
-rw-r--r--dev-ros/realtime_tools/realtime_tools-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/Manifest b/dev-ros/realtime_tools/Manifest
new file mode 100644
index 000000000000..bdf6fc64c573
--- /dev/null
+++ b/dev-ros/realtime_tools/Manifest
@@ -0,0 +1 @@
+DIST realtime_tools-1.9.1.tar.gz 8820 SHA256 1de97577326d4f87932eec94b4a46587c20f8989a69997ef613a0a79c375da2d SHA512 7aa007acc922ecade003a1002be31905fa109ac827989f78df74e6c160a64107356f9e2a0153576b8ca993f3812be39661677aaae37fe690b327e5c3511f5a07 WHIRLPOOL 38d9d92df0d6cba3ab2cbfad7ae82d6e456cfdcde6c67b88b92c134acd2487e73ec48a253460a04d42c972d7dc8ae63acd27dd76924c6862004c6ceea7281166
diff --git a/dev-ros/realtime_tools/metadata.xml b/dev-ros/realtime_tools/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/realtime_tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/realtime_tools/realtime_tools-1.9.1.ebuild b/dev-ros/realtime_tools/realtime_tools-1.9.1.ebuild
new file mode 100644
index 000000000000..88c591a6733d
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.9.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/realtime_tools/realtime_tools-9999.ebuild b/dev-ros/realtime_tools/realtime_tools-9999.ebuild
new file mode 100644
index 000000000000..88c591a6733d
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"