summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-04 22:46:40 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-04 22:46:40 +0100
commitd2b13688e2aec80b26063c676c549e524d0dea5e (patch)
treed6d39aed1be2f0532c18bebe085e104714a9f16c /dev-ros
parentdev-ros/rqt_topic: bump to 0.4.10 (diff)
downloadgentoo-d2b13688e2aec80b26063c676c549e524d0dea5e.tar.gz
gentoo-d2b13688e2aec80b26063c676c549e524d0dea5e.tar.bz2
gentoo-d2b13688e2aec80b26063c676c549e524d0dea5e.zip
dev-ros/pluginlib: bump to 1.11.2
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/pluginlib/Manifest3
-rw-r--r--dev-ros/pluginlib/files/catkin_prefix_path2.patch15
-rw-r--r--dev-ros/pluginlib/pluginlib-1.11.2.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-9999.ebuild2
4 files changed, 45 insertions, 2 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index ccb761bb5d62..c6a0a36a4c54 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1 +1,2 @@
-DIST pluginlib-1.11.1.tar.gz 21621 SHA256 bee838a9e62c8e889e8354f6ec5c76493f3aa6df5d19c30110068c82feb927c0 SHA512 1bafbc35334a482b2fc08afb7c1ed53ddbc579b121b728b96893c8b82a7070d9ecd8e6e6cffa54b3539def84db9dac79fe59feb93b2de6b8f113e0bfc10a8c00 WHIRLPOOL 1d05ddb55c800e0272e6c203804fdd0cdc966a6213df55a999e2ab5f14ff157ec84654d6155a1de77cdd15821776ad51918e0fa1072efbc1c08e539dd10ebce3
+DIST pluginlib-1.11.1.tar.gz 21621 BLAKE2B 911cc5bb5752e74d90b6d2dc61cb67367fc69a3e375ef827fea49a0e0d4367f0bba6923960e7112c9ed5909b8e50738b2178a5c04d20abe4b8716559e5ebe0e1 SHA512 1bafbc35334a482b2fc08afb7c1ed53ddbc579b121b728b96893c8b82a7070d9ecd8e6e6cffa54b3539def84db9dac79fe59feb93b2de6b8f113e0bfc10a8c00
+DIST pluginlib-1.11.2.tar.gz 22844 BLAKE2B 3f3090b2b41754c0989cbc2c0f31333cf404aca00c481c3062955b01274b1cddb76eef41a0bce9a01058b461a293d42beae7c9337e8780d1e9503968196f0a98 SHA512 579aeb2ae82d6607c62007a5be6ccc402856c135e69a500d530ce5569c4f77526a63fee8b948db997db2face37bdac929b58911b5245c6ad641d19af055e46c0
diff --git a/dev-ros/pluginlib/files/catkin_prefix_path2.patch b/dev-ros/pluginlib/files/catkin_prefix_path2.patch
new file mode 100644
index 000000000000..12e759c63216
--- /dev/null
+++ b/dev-ros/pluginlib/files/catkin_prefix_path2.patch
@@ -0,0 +1,15 @@
+Honour CATKIN_PREFIX_PATH at runtime instead of ROS' hack to use CMAKE_PREFIX_PATH.
+
+Index: pluginlib-1.11.2/include/pluginlib/class_loader_imp.hpp
+===================================================================
+--- pluginlib-1.11.2.orig/include/pluginlib/class_loader_imp.hpp
++++ pluginlib-1.11.2/include/pluginlib/class_loader_imp.hpp
+@@ -68,7 +68,7 @@ namespace
+ std::vector<std::string> catkinFindLib()
+ {
+ std::vector<std::string> lib_paths;
+- const char * env = std::getenv("CMAKE_PREFIX_PATH");
++ const char * env = std::getenv("CATKIN_PREFIX_PATH");
+ if (env) {
+ std::string env_catkin_prefix_paths(env);
+ std::vector<std::string> catkin_prefix_paths;
diff --git a/dev-ros/pluginlib/pluginlib-1.11.2.ebuild b/dev-ros/pluginlib/pluginlib-1.11.2.ebuild
new file mode 100644
index 000000000000..d72ce338bb94
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.11.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-9999.ebuild b/dev-ros/pluginlib/pluginlib-9999.ebuild
index 730a3b5305de..d72ce338bb94 100644
--- a/dev-ros/pluginlib/pluginlib-9999.ebuild
+++ b/dev-ros/pluginlib/pluginlib-9999.ebuild
@@ -24,4 +24,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/catkin_prefix_path.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )