summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-23 08:39:06 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-23 09:50:54 +0200
commitb88db2b4981891004d5822e554c8d3ed943a9ca0 (patch)
treea76010619aaf74a798e28356097b94913a918f26 /dev-ruby/best_in_place
parentapp-crypt/xca: remove qt4 (diff)
downloadgentoo-b88db2b4981891004d5822e554c8d3ed943a9ca0.tar.gz
gentoo-b88db2b4981891004d5822e554c8d3ed943a9ca0.tar.bz2
gentoo-b88db2b4981891004d5822e554c8d3ed943a9ca0.zip
dev-ruby/best_in_place: cleanup
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/Manifest1
-rw-r--r--dev-ruby/best_in_place/best_in_place-3.1.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-ruby/best_in_place/Manifest b/dev-ruby/best_in_place/Manifest
index 89a68fde2828..b725d0f4ca77 100644
--- a/dev-ruby/best_in_place/Manifest
+++ b/dev-ruby/best_in_place/Manifest
@@ -1,2 +1 @@
-DIST best_in_place-3.1.0.gem 73728 SHA256 4bc57e238e2a4f4b01b7c464fec4ea814189b180431deb603cc1db3fe00bc33c SHA512 5296392d2534e8eb7c01eeee36530259a10c4d7cb5765bb2bd76944c9bc93e4202135cf2a656283bbf24041986f80b0bf2ec613c27c3368aeee7fae32c6bc6dd WHIRLPOOL 84f262964e42d767d5f355eb0236fbe2c8e948ff98292e7ddd3fe2315eb3707a900f2691dce6c0301da2b170828ce75767b2aac633c057b145a4d69e4438b317
DIST best_in_place-3.1.1.gem 75264 SHA256 5a682a28b001a0f3bc557ea82085bc2bc29122115d662c8707b040a192aa2765 SHA512 f6a26590769f8d6ab6b6bf9ef955e2c26b6116ab82ccaf3bc26cfae435cb0bc594facae6dcb052bafdaaeb5806f7091eb9ad21e51940030eadd437ae342f1d33 WHIRLPOOL b3f4549b4ba2219376b759858637ccc4f3dbf277f0fc31e50d8c92506c35429fb07e2ac7d6d10c4f004ac45eec91bdb125b44afc5dc551da976b5293581c4c12
diff --git a/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild b/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild
deleted file mode 100644
index 40a701276a51..000000000000
--- a/dev-ruby/best_in_place/best_in_place-3.1.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="bernat"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit virtualx ruby-fakegem
-
-DESCRIPTION="In-place editor helper for Rails 3"
-HOMEPAGE="https://github.com/bernat/best_in_place"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/actionpack-3.2:*
- >=dev-ruby/railties-3.2:*
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/rdiscount
- dev-ruby/rspec-rails:3
- >=dev-ruby/nokogiri-1.5.0
- >=dev-ruby/capybara-1.1.2:0
- >=dev-ruby/rails-3.2
- >=dev-ruby/sqlite3-1.3.4-r1
- dev-ruby/bundler
- )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Tweak Gemfile so we can use it to run specs but can avoid missing
- # dependencies. Also use packaged versions of jquery and jquery-ui.
- sed -i -e '/\(rails-assets\|appraisal\)/ s:^:#:' \
- -e '2agem "rspec", "~>3.0"' \
- -e '2agem "jquery-rails"' -e '2agem "jquery-ui-rails"' \
- -e '/byebug/ s:^:#:' \
- -e '/\(launchy\|poltergeist\)/d' \
- Gemfile
- sed -i -e '/poltergeist/,/javascript_driver/ s:^:#:' spec/rails_helper.rb || die
-
- # Remove integration tests. They fail to run and depend on obsolete
- # poltergeist/phantomjs.
- rm -rf spec/integration || die
-}
-
-each_ruby_test() {
- ${RUBY} -S bundle exec rspec-3 spec || die
-}