summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/childlabor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/childlabor')
-rw-r--r--dev-ruby/childlabor/Manifest1
-rw-r--r--dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild37
-rw-r--r--dev-ruby/childlabor/metadata.xml8
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/childlabor/Manifest b/dev-ruby/childlabor/Manifest
new file mode 100644
index 000000000000..279de2a41f7b
--- /dev/null
+++ b/dev-ruby/childlabor/Manifest
@@ -0,0 +1 @@
+DIST childlabor-0.0.3.tar.gz 3120 SHA256 95dbc1d5127545e44eddefd973c9285208da8bdffca7a59300cee6e882847e8c SHA512 d18f3f90204b12e3b4a21be1439fcf44a4eb9f905402633966e6ab2a3cc9412a28c502a8c78487834a82e1de24f0f905691f33f443de930f670c70b17288fb6e WHIRLPOOL 9938bc47695fa7d77b3155c1ea5a8c663488efc5e2419a823f6238b0a8181a23f26d789e1b497a2ff8f39b36fe5232e2eca6de1e677caf141ea82cf0b9eea9d5
diff --git a/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..0ca01e63f61e
--- /dev/null
+++ b/dev-ruby/childlabor/childlabor-0.0.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="https://github.com/carllerche/childlabor"
+COMMIT_ID="6518b939dddbad20c7f05aa075d76e3ca6e70447"
+SRC_URI="https://github.com/carllerche/childlabor/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RUBY_S="${PN}-${COMMIT_ID}"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Avoid failing spec. The signals work, but the stdout handling
+ # doesn't seem to play nice with portage.
+ sed -i -e '/can send signals/,/^ end/ s:^:#:' spec/task_spec.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_rspec -I. spec/task_spec.rb || die
+}
diff --git a/dev-ruby/childlabor/metadata.xml b/dev-ruby/childlabor/metadata.xml
new file mode 100644
index 000000000000..b931aaca399c
--- /dev/null
+++ b/dev-ruby/childlabor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">carllerche/childlabor</remote-id>
+ </upstream>
+</pkgmetadata>