summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/compass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/compass')
-rw-r--r--dev-ruby/compass/Manifest2
-rw-r--r--dev-ruby/compass/compass-1.0.1-r1.ebuild41
-rw-r--r--dev-ruby/compass/compass-1.0.3-r1.ebuild43
-rw-r--r--dev-ruby/compass/metadata.xml13
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-ruby/compass/Manifest b/dev-ruby/compass/Manifest
new file mode 100644
index 000000000000..8e575ceee8fa
--- /dev/null
+++ b/dev-ruby/compass/Manifest
@@ -0,0 +1,2 @@
+DIST compass-1.0.1.gem 379392 SHA256 80c40c6c5974af98200064a7deabaa1ebc9bde5ef392c5f9179f9f219735ab33 SHA512 a2f1ff4ce6a6df9170d1056d9e8be7067ca9ec653fa50cb05d12a740de6628478c251d024fd6c6209c801b0fffe43ef1f653b7a106be7875a81eca5f1c8d1db5 WHIRLPOOL 4053db34dcdcfd9caea8e6a9778f13ffb83e3c55bf3011c5d271f290fe6f1ad10075f22a0182ea7bdd9694c364bcb36aa4112d35ba5af6abfd676429ea339999
+DIST compass-1.0.3.gem 378368 SHA256 4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151 SHA512 bef1ca903cb982df39330a913051c1a330aa1ecad9abbe5a7644e335c7ed2d152901a4079cc5ee43e9f7ce85a671f1d5552a3c98cf40b04134de072a120deef6 WHIRLPOOL b1b07e028dffcb370abca70815442758691e7373bac8b51b994136bb0a746eec4d79fddbad53c431286ff58d7bd9aaf49619e72f7a926b8c18b5dc7ca0f15e09
diff --git a/dev-ruby/compass/compass-1.0.1-r1.ebuild b/dev-ruby/compass/compass-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..941b52e1e4d3
--- /dev/null
+++ b/dev-ruby/compass/compass-1.0.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test features"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Gem does not contain all files needed to run specs and it is not clear
+# which upstream repository/branch/directory to use.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/chunky_png-1.2
+ >=dev-ruby/compass-core-1.0.1:1.0
+ >=dev-ruby/compass-import-once-1.0.5:1.0
+ >=dev-ruby/rb-inotify-0.9
+ >=dev-ruby/sass-3.3.13 <dev-ruby/sass-3.5
+ !!<dev-ruby/compass-0.12.7-r1"
+
+#ruby_add_bdepend "test? ( dev-ruby/colorize )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Remove rb-fsevent dependency since it is not needed on Linux and
+ # not packaged.
+ sed -i -e '/rb-fsevent/,/^-/ s:^:#:' ../metadata || die
+}
diff --git a/dev-ruby/compass/compass-1.0.3-r1.ebuild b/dev-ruby/compass/compass-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..e5e64e53f0cb
--- /dev/null
+++ b/dev-ruby/compass/compass-1.0.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test features"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Gem does not contain all files needed to run specs and it is not clear
+# which upstream repository/branch/directory to use.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/chunky_png-1.2
+ >=dev-ruby/compass-core-1.0.2:1.0
+ >=dev-ruby/compass-import-once-1.0.5:1.0
+ >=dev-ruby/rb-inotify-0.9
+ >=dev-ruby/sass-3.3.13 <dev-ruby/sass-3.5
+ !!<dev-ruby/compass-0.12.7-r1"
+
+#ruby_add_bdepend "test? ( dev-ruby/colorize )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Remove rb-fsevent dependency since it is not needed on Linux and
+ # not packaged.
+ sed -i -e '/rb-fsevent/,/^-/ s:^:#:' ../metadata || die
+}
diff --git a/dev-ruby/compass/metadata.xml b/dev-ruby/compass/metadata.xml
new file mode 100644
index 000000000000..ba11df1021de
--- /dev/null
+++ b/dev-ruby/compass/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury (vikraman)</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compass is a Sass-based Stylesheet Framework that streamlines the
+ creation and maintenance of CSS.
+ </longdescription>
+</pkgmetadata>