summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/css_parser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/css_parser')
-rw-r--r--dev-ruby/css_parser/Manifest2
-rw-r--r--dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild43
-rw-r--r--dev-ruby/css_parser/css_parser-1.3.6.ebuild43
-rw-r--r--dev-ruby/css_parser/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-ruby/css_parser/Manifest b/dev-ruby/css_parser/Manifest
new file mode 100644
index 000000000000..1c28956093a1
--- /dev/null
+++ b/dev-ruby/css_parser/Manifest
@@ -0,0 +1,2 @@
+DIST css_parser-1.3.5.tar.gz 23699 SHA256 d08f0a28e97d2d8e80bebe1253ed68f98a75f6afbc5f453a570170972d3af08e SHA512 92897839387649379f35d9b0368cab9d5c8148c588a421f155f5ff6bdc6e7b9d776ccc267d73a2484c48c4d4d6084f99c86ba84c20f3025952dcb9b84c1a3901 WHIRLPOOL f32766fb8727245db9d9f6b8f764fbbddff865e0378b42904da58a6385ed697df053be6948244278bf231ec8d667c81693c6753840d17a48f4d7c8f03fca51b6
+DIST css_parser-1.3.6.tar.gz 24422 SHA256 1931ca0a02d14a0ae7863921a18f3475fa6beee58585e9949af70ceffed8fc80 SHA512 a9d09a95320b3a6853a5f079c17d2913868a3d97ee20d9df8076d9206721bf23442e793a722e67c87d4083d3734ba9eaf98b81d93e6257aaaa43ff32b8e6e65b WHIRLPOOL 13ca571034974d09bf4165f1ca8cc947d66aafdacbd098e25e1f16e312bcbe3bf850b2d1f62d404c0878641f0e9b60c5a00f2b24007295cc0881299f5eb4767f
diff --git a/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild b/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..3b472ba6f281
--- /dev/null
+++ b/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_DIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="premailer"
+GITHUB_PROJECT="${PN}"
+inherit ruby-fakegem
+
+DESCRIPTION="Sass-based Stylesheet Framework"
+HOMEPAGE="http://compass-style.org/"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/addressable
+ virtual/ruby-ssl"
+
+all_ruby_prepare() {
+ # get rid of bundler usage
+ rm Gemfile || die
+ sed -i -e '/bundler/d' -e '/bump/d' Rakefile || die
+ sed -i -e '/bundler/d' test/test_helper.rb || die
+ # Avoid tests using the network.
+ sed -i -e '/test_loading_a_remote_file_over_ssl/,/end/ s:^:#:' test/test_css_parser_loading.rb || die
+
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/*.rb || die
+}
diff --git a/dev-ruby/css_parser/css_parser-1.3.6.ebuild b/dev-ruby/css_parser/css_parser-1.3.6.ebuild
new file mode 100644
index 000000000000..9ff4ed1c8c47
--- /dev/null
+++ b/dev-ruby/css_parser/css_parser-1.3.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_DIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="premailer"
+GITHUB_PROJECT="${PN}"
+inherit ruby-fakegem
+
+DESCRIPTION="Sass-based Stylesheet Framework"
+HOMEPAGE="http://compass-style.org/"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/addressable
+ virtual/ruby-ssl"
+
+all_ruby_prepare() {
+ # get rid of bundler usage
+ rm Gemfile || die
+ sed -i -e '/bundler/d' -e '/bump/d' Rakefile || die
+ sed -i -e '/bundler/d' test/test_helper.rb || die
+ # Avoid tests using the network.
+ sed -i -e '/test_loading_a_remote_file_over_ssl/,/end/ s:^:#:' test/test_css_parser_loading.rb || die
+
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/*.rb || die
+}
diff --git a/dev-ruby/css_parser/metadata.xml b/dev-ruby/css_parser/metadata.xml
new file mode 100644
index 000000000000..059c0ea95d4c
--- /dev/null
+++ b/dev-ruby/css_parser/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">premailer/css_parser</remote-id>
+ </upstream>
+</pkgmetadata>