summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-19 07:31:38 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-19 07:31:38 +0200
commita6f8335d3900eb9f5dd91cd8e798d1fe22bae1e3 (patch)
treebfbe7a63dc1b0dd49933299fae2f731a1f2b89f7 /dev-ruby/dnsruby/dnsruby-1.61.2.ebuild
parentdev-ruby/bundler: add 1.16.3 (diff)
downloadgentoo-a6f8335d3900eb9f5dd91cd8e798d1fe22bae1e3.tar.gz
gentoo-a6f8335d3900eb9f5dd91cd8e798d1fe22bae1e3.tar.bz2
gentoo-a6f8335d3900eb9f5dd91cd8e798d1fe22bae1e3.zip
dev-ruby/dnsruby: add 1.61.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/dnsruby/dnsruby-1.61.2.ebuild')
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.61.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/dnsruby/dnsruby-1.61.2.ebuild b/dev-ruby/dnsruby/dnsruby-1.61.2.ebuild
new file mode 100644
index 000000000000..305d820349e9
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.61.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}