summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-11-23 16:12:02 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-11-23 16:16:31 -0600
commit4315b90a64d39d9f3ca5ecff2588b0eb86ce4341 (patch)
tree04ac8d8c7ed20f7cb321e3fe295cd2c8270f9fde /dev-ruby/facter
parentapp-admin/mcollective: 2.12.4 stable amd64 and x86 with cleanup (diff)
downloadgentoo-4315b90a64d39d9f3ca5ecff2588b0eb86ce4341.tar.gz
gentoo-4315b90a64d39d9f3ca5ecff2588b0eb86ce4341.tar.bz2
gentoo-4315b90a64d39d9f3ca5ecff2588b0eb86ce4341.zip
dev-ruby/facter: 3.12.1 stable amd64 and x86 with cleanup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.12.0.ebuild110
-rw-r--r--dev-ruby/facter/facter-3.12.1.ebuild2
3 files changed, 1 insertions, 112 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 1ad6c72ea6f9..2d2f067a6ec7 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,4 +1,3 @@
DIST facter-2.4.6.gem 246272 BLAKE2B 105a43b2697cde0a48d4fcf87e221cfcb348695f81722b8cfe2819a8f3fe19e575d22642a708c798648d05c71f54e7bf0281345320612a8fdb3b68fce993ec20 SHA512 a0a2bef37451ab96ed331c79171f77d89b6db430b083e6888a306fa5b57a72986b7f600cad3e09b5f4706e54736d1d32ea25525fe18a6108cc95f315da16664a
-DIST facter-3.12.0.tar.gz 390445 BLAKE2B 8c7f2fccd16df3b13df451c18eaeb0cb837d1408b247bbf35f264e3adc2daeb5efaf3008ecf95428433d19067310b2d273a6001e1e151c260d7777dd5185f54b SHA512 2ef78903f62784f86f8d155f9f10ba793c10742f87d80c894c6bd505ae9186b5e875366d9c05899fe5e25f2994cf66b7d73d6c6570a38a7bc6e45ff0d5108c36
DIST facter-3.12.1.tar.gz 390863 BLAKE2B 3326fc52e95e73c3f083fead5b9e5c6e4fa691d99c5948dc2ffb1a1aeebc928e6a08dd4d09b417cbb33cecb776d75c488956df7b2fb9c5f937a20788ad3466f4 SHA512 34ed1cb50a38a8137301682c46c91c6b409be78c6349677b6544e082fb388248c4878719f57327b6ee4d0d2f35ff171a62afe5e3cc5972e0e9b24e3239a23216
DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.12.0.ebuild b/dev-ruby/facter/facter-3.12.0.ebuild
deleted file mode 100644
index 47277b802f63..000000000000
--- a/dev-ruby/facter/facter-3.12.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-BDEPEND="
- >=sys-devel/gcc-4.8:*
- dev-cpp/cpp-hocon"
-COMMON_DEPEND="
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:*
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- >=dev-libs/boost-1.54:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
- ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- # be explicit about the version of rspec we test with
- sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
- CMakeLists.txt || die
- # be more lenient for software versions for tests
- sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
- -e '/rspec/ s/2.11.0/2.11/' \
- -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
- # patches
- default
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.12.1.ebuild b/dev-ruby/facter/facter-3.12.1.ebuild
index 21124e27b591..47277b802f63 100644
--- a/dev-ruby/facter/facter-3.12.1.ebuild
+++ b/dev-ruby/facter/facter-3.12.1.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_BRANCH="master"
else
[[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi