summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-05 07:50:36 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-05 07:51:16 +0100
commit2fe33766b17b143f9d514feb5c1e27e32dae7958 (patch)
treeb2b7d14027a262fa3b11a959cfbde8f8d0474f6c /dev-ruby/mixlib-shellout
parentdev-ruby/mixlib-shellout: cleanup (diff)
downloadgentoo-2fe33766b17b143f9d514feb5c1e27e32dae7958.tar.gz
gentoo-2fe33766b17b143f9d514feb5c1e27e32dae7958.tar.bz2
gentoo-2fe33766b17b143f9d514feb5c1e27e32dae7958.zip
dev-ruby/mixlib-shellout: add 2.2.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest1
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.2.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index 8a4eddd13ed6..14f1e676af5f 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1 +1,2 @@
DIST mixlib-shellout-2.2.5.tar.gz 34197 SHA256 7ae14c18731359e823ecadece612480cb7097e4d73a0f07158452dd46c86d7c7 SHA512 5d65c3665ef2a51fe9468268efc595cded6a798cd8a1879f12a3e7712be718cad0706a2602406683d039f1e4675a8e023f2cce8d9d4e3af8e95d7597c8381826 WHIRLPOOL 813395d956296b70bfc97e26fcbce047acf228664cada0642bff504d29d65b460daa3cb7ce6eb7e8fa2af5be7034123fc4e5d839ac01aae25fa8e6937eb575bb
+DIST mixlib-shellout-2.2.6.tar.gz 34296 SHA256 55e98741c35edfa5149d1c046dac898504c22747840a96baee2e98d15b41f5ea SHA512 f329c19ae560ac36349efa106600aa52287fbfb89aebeebbc3a0865bc81b97216a21f59517a904ca558000808546c4f7d05768f50a82e2488c1b016454f000b2 WHIRLPOOL 20d48ca4f9eadedc130bea1c470307ec4c7bdb18fea6cd8fa9bbf3563ed1d17cd55f0d937971d35f147f62ef917c2b75b95970a5115864e69b06c8b2de82ed13
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.6.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.6.ebuild
new file mode 100644
index 000000000000..4b84f8033293
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}