summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-01 07:58:02 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-01 07:58:02 +0200
commit0e2bb825a111f6ddbbb4eca011ca7e4d5415dfc3 (patch)
tree9b99d1335ee241a51f595f200248df736f74d805 /dev-ruby/oauth
parentdev-ruby/puppetdb-termini: enable ruby30, ruby31 and disable ruby25 (diff)
downloadgentoo-0e2bb825a111f6ddbbb4eca011ca7e4d5415dfc3.tar.gz
gentoo-0e2bb825a111f6ddbbb4eca011ca7e4d5415dfc3.tar.bz2
gentoo-0e2bb825a111f6ddbbb4eca011ca7e4d5415dfc3.zip
dev-ruby/oauth: drop 0.5.6, 0.5.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest2
-rw-r--r--dev-ruby/oauth/oauth-0.5.6.ebuild39
-rw-r--r--dev-ruby/oauth/oauth-0.5.7.ebuild39
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index f6bf356a4632..95e7a931f2d8 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1,3 +1 @@
-DIST oauth-0.5.6.tar.gz 60887 BLAKE2B 8dea7bc6b1a3c9d5befa5badbda105fed28004d6627624fedaf1572cc261421e3a8636019bb0a600a28fb6aa933d2b1be5faf613ae3062f7d50b314b86059b17 SHA512 dcb516b90d6cf0ff3f1071fa7bf1e1b30cd998c79205f9a6df001d5c04784ad23ecd430b4e04565a6351efcc780b552dfc38ea962d0a938c9e19a6e5bd3fe070
-DIST oauth-0.5.7.tar.gz 65889 BLAKE2B 71787b6a03156a25edbb006acd05f7aae789e9bc0fffa0afe9d3f0c55a2b991fa20527c493e9933891adc0e32571c1834f1a3f928e12f2a7b3159ebc09d29286 SHA512 4bc217123aaf74482ed118344c57b241b9efea172d872d670a860e8f236fac4ae1956826fcc786025164a5728c62edded8cb453f0051091c48bc87fe1f72f931
DIST oauth-0.5.8.tar.gz 67852 BLAKE2B 7dc19a2f84f585fd517d677bf441c5964b45566ffea3cbd7612061db115a5570cf8315b4cbdd8788f9b0ff336b6eea91922f17c0ce17a4c626731282bd8203ca SHA512 3bf8298ea5bcffe1fe61ba894a5cfcb04a5814348154749e056ea18d975b00b10db7ed226f2187ffb9f414b755022bf32ff4bb2c02f1f429f6a9a7062032d82e
diff --git a/dev-ruby/oauth/oauth-0.5.6.ebuild b/dev-ruby/oauth/oauth-0.5.6.ebuild
deleted file mode 100644
index 7fdf4be49c41..000000000000
--- a/dev-ruby/oauth/oauth-0.5.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
-
-RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/bundler
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack
- dev-ruby/actionpack:6.0
- dev-ruby/railties:6.0
-)"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.0.0" ; gem "actionpack", "~>6.0.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
- -e '/mocha/ s/mini_test/minitest/' \
- -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
-}
diff --git a/dev-ruby/oauth/oauth-0.5.7.ebuild b/dev-ruby/oauth/oauth-0.5.7.ebuild
deleted file mode 100644
index cdb746579c6c..000000000000
--- a/dev-ruby/oauth/oauth-0.5.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/bundler
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack
- dev-ruby/actionpack:6.0
- dev-ruby/railties:6.0
-)"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.0.0" ; gem "actionpack", "~>6.0.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
- -e '/mocha/ s/mini_test/minitest/' \
- -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
-}