summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-03 07:41:49 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-03 07:43:19 +0100
commit5f5663c8e033306b15604942562a4851ba527ecc (patch)
tree21fc5cd4236aa82e0633e14851c448b8e525d9d9 /dev-ruby/oauth
parentdev-ruby/descendants_tracker: add ruby30 (diff)
downloadgentoo-5f5663c8e033306b15604942562a4851ba527ecc.tar.gz
gentoo-5f5663c8e033306b15604942562a4851ba527ecc.tar.bz2
gentoo-5f5663c8e033306b15604942562a4851ba527ecc.zip
dev-ruby/oauth: add 0.5.7
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest1
-rw-r--r--dev-ruby/oauth/oauth-0.5.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index 45230fd3af3c..c9b32ecea0b5 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1 +1,2 @@
DIST oauth-0.5.6.tar.gz 60887 BLAKE2B 8dea7bc6b1a3c9d5befa5badbda105fed28004d6627624fedaf1572cc261421e3a8636019bb0a600a28fb6aa933d2b1be5faf613ae3062f7d50b314b86059b17 SHA512 dcb516b90d6cf0ff3f1071fa7bf1e1b30cd998c79205f9a6df001d5c04784ad23ecd430b4e04565a6351efcc780b552dfc38ea962d0a938c9e19a6e5bd3fe070
+DIST oauth-0.5.7.tar.gz 65889 BLAKE2B 71787b6a03156a25edbb006acd05f7aae789e9bc0fffa0afe9d3f0c55a2b991fa20527c493e9933891adc0e32571c1834f1a3f928e12f2a7b3159ebc09d29286 SHA512 4bc217123aaf74482ed118344c57b241b9efea172d872d670a860e8f236fac4ae1956826fcc786025164a5728c62edded8cb453f0051091c48bc87fe1f72f931
diff --git a/dev-ruby/oauth/oauth-0.5.7.ebuild b/dev-ruby/oauth/oauth-0.5.7.ebuild
new file mode 100644
index 000000000000..cdb746579c6c
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.5.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
+
+RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
+HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
+SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:1.0
+ dev-ruby/webmock
+ dev-ruby/rack
+ dev-ruby/actionpack:6.0
+ dev-ruby/railties:6.0
+)"
+
+all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.0.0" ; gem "actionpack", "~>6.0.0"' \
+ -e '2i gem "test-unit"; require "test/unit"' \
+ -e '/mocha/ s/mini_test/minitest/' \
+ -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+}