summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-07 09:36:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-07 09:42:27 -0600
commit222a3d210a394313890cf0d9939dd702df207601 (patch)
treee3d35112e9202c416435cac0f76a6a5bff965031 /dev-ruby/puppetdb-termini
parentapp-admin/augeas: 1.7.0 stable amd64 and x86 (diff)
downloadgentoo-222a3d210a394313890cf0d9939dd702df207601.tar.gz
gentoo-222a3d210a394313890cf0d9939dd702df207601.tar.bz2
gentoo-222a3d210a394313890cf0d9939dd702df207601.zip
dev-ruby/puppetdb-termini: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 1e9c4f77fcb2..17eedf18457d 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,3 +1,4 @@
DIST puppetdb-termini_3.0.1-1puppetlabs1_all.deb 21662 SHA256 a1930ded1549187b9c6d1bbd267b0ffe353f498cd053364349a99ed34214c614 SHA512 7ddbf0ae264fcf6063ba180e6ba19e1c491ece7f11b761f6fa66ba39c89de6e7b1a14efa04a113e553892bf987f79f3175dd950f55ce05b985ef7ea19e470ab0 WHIRLPOOL 204d8f8889e4725cf515ce23b5f8b3c5c987899751e2c1a43acae3ef92d7c8297921cc60c739d3fa6f77259b1e539a40b70e9cf081ab15509f21ef5a0b892a2e
DIST puppetdb-termini_3.1.0-1puppetlabs1_all.deb 21074 SHA256 58b7f2cd7f374c7d3be69be5d53b8def650b8cddf8848619981451532cfcc4eb SHA512 ac265806f33bbde23825a09f19710ee99e0f12195d921033aa156641e7c092e3ceefa40a855ce39a216ca486bf0d898d27ca3801be01af6f2e47b7582004c0bc WHIRLPOOL add162e4d66474cee3e6291c4305917128c3840fd8abda3ce4ff78337e1ac8c23a616fd5074f098f1036a9be75f21c27aa906c632cc49e5e2031a13b02d423bd
DIST puppetdb-termini_3.2.3-1puppetlabs1_all.deb 22028 SHA256 b5461dac4bff77530b071dcffe270e896846eefdb83aa65d70cfdfab6eafda1f SHA512 d7f789f73a8e82e7cc291631577574aa75357a8a404f6949127749f26209c6f3017472afedcc1ce73b2d118b946423db059c7e840ad00828b491b1631321879b WHIRLPOOL 78be90206062adf49ace4518aa65d7a88ca18cd34a4b20857c03f7434103e0145f38018f7312b4c3514940c346e643e662bcbaf6974bd6ffe1af102afce5b493
+DIST puppetdb-termini_4.3.0-1puppetlabs1_all.deb 18522 SHA256 02f7a02f42364ad7bd7455c3c0668561b51f9bf1efca38f06a751128f594d789 SHA512 088ed402df9d8fed0827cdca47c782690a7ab767e2fc786dd94a1019cd84c5dd70168bddac43963031c89bc3a1a545d81554952c9fdc999f52d49e2b6212f9ef WHIRLPOOL 63303fe0cfdb45ad9919e5af2ceef31237dcb50c11ed5109d2e113c2f657d8a141c06ad6a1b2e83d9fea0177f3c6772b42637f47e29531bd9834a1d306b2c81c
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild
new file mode 100644
index 000000000000..2cc338be44aa
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-4.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/puppetdb/${PN}_${PV}-1puppetlabs1_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}