summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-11 06:59:32 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-11 07:40:36 +0200
commitd8569b2312139a2570097ff65e167c82d60583d9 (patch)
tree44ab70d47f75e06786dbd5632a0a19c16fed861c /dev-ruby/rspec-expectations
parentdev-ruby/capybara: add 3.23.0 (diff)
downloadgentoo-d8569b2312139a2570097ff65e167c82d60583d9.tar.gz
gentoo-d8569b2312139a2570097ff65e167c82d60583d9.tar.bz2
gentoo-d8569b2312139a2570097ff65e167c82d60583d9.zip
dev-ruby/rspec-expectations: add 3.8.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.8.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index a7561379b734..82420b173635 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -2,3 +2,4 @@ DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc
DIST rspec-expectations-3.7.0-git.tgz 194071 BLAKE2B 67c8db15c43cc1141b19c6eb99390eaaf2535ec03f0fdc7b05576daa463d252f56ff251d40f5771726ee6451d57eef206c893f2593b01d413b5d96cdf21f0daf SHA512 bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a
DIST rspec-expectations-3.8.2-git.tgz 198952 BLAKE2B 6952f895251f26f8a1b7746b277fc92b296e78fb23b8f581e90f649ccc28e21e0a695f87b012b4925becfcda8f8876414f74a826c75bdfa5114092849bbfe525 SHA512 d374f7add45d2b6ce607c1a068e3e0970f902a0edf96ec891bd618dd17253878c1e0b625296ff12a6dc35103651bbfbcfd1a1b444f94e08eae2680e32853a198
DIST rspec-expectations-3.8.3-git.tgz 200239 BLAKE2B 88295c7df00a99486bb19ae37ee74a857a087afdb4c14eb6db8c343e639ef322c45ab9de25b0c70707a9f17cbc81c47baff8b7695fc6a1440de5509b1508cb1f SHA512 328b3403e7ac2864ed6ad1a196ca24df6693797e35525559f2082c7e1c161d60da7776ca1a68a82364a7ea55115ac2c12ebf6af8486ef88757a4818a9683ae80
+DIST rspec-expectations-3.8.4-git.tgz 200149 BLAKE2B 45fe4cdc4b032bb773ef0e7d3e9b75e6d14a6e8c1850ad6fd84991d85a61860730caa9f191aa9d1ce4e21c85dadd2c52bb69bd0a1454f5ab918dc1e563fc54f1 SHA512 0ecb16f11ccf19c02c40ce587f33846fb2241f1663dd87f012b9b782338c213362dac624c434dee6e00ad2cc7ec4a1cd0af7f2edf1a8e9ebb0a0dfb31cd244d8
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.8.4.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.8.4.ebuild
new file mode 100644
index 000000000000..647c42d8500a
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.8.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}